【寒假】POJ 3984(bfs+路径还原)

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
解题思路是bfs+路径还原,用另外一个结构数组来保存路径。
front和rear有点难理解,但当你把每一步怎么走给画出来就懂了。

#include<iostream>
#include<queue>
using namespace std;
int map[5][5];
int maze[5][5];
int d[4][2] = { {-1,0},{1,0},{0,-1},{0,1} };
struct loc
{
	int x;
	int y;
	//int step;
	int front;
};
int front = 0;
int rear = 0;
queue<loc>p;
loc q[100];
void print(loc f)
{
	if (f.front == -1)
		cout << "(" << f.x << ", " << f.y << ")" << endl;
	else {
		print(q[f.front]);
		cout << "(" << f.x << ", " << f.y << ")" << endl;
	}

}
void bfs()
{
	loc first;
	loc second;
	first.x = 0;
	first.y = 0;
	maze[0][0] = 1;
	p.push(first);
	q[rear].x = 0;
	q[rear].y = 0;
	q[rear].front = -1;
	rear++;
	while (p.empty() == 0)
	{
		first = p.front();
		p.pop();
		if (first.x == 4 && first.y == 4)
		{
			print(q[rear - 1]);
			return;
		}
		second = first;
		for (int i = 0; i < 4; i++)
		{
			second.x = first.x + d[i][0];
			second.y = first.y + d[i][1];
			if (second.x >= 0 && second.x < 5 && second.y >= 0 && second.y < 5 && maze[second.x][second.y] == 0)
			{
				q[rear].x = second.x;
				q[rear].y = second.y;
				q[rear].front = front;
				p.push(second);
				maze[second.x][second.y] = 1;
				rear++;
			}
		}
		front++;
	}
}
int main()
{
	for (int i = 0; i < 5; i++)
		for (int j = 0; j < 5; j++)
			cin >> maze[i][j];
	bfs();
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值