c++排序与检索,sort与lower_bound的应用。

现在有n个大理石,每个大理石上面都有一个非负整数,首先把各个数字从小到大排序,然后回答Q个问题。每个问题问是否有一个大理石上写着某个整数x如果是,还要回答那个大理石上面写着x,排序后的大理石的从左到右的标号为1~n。

样例输入:
4 1
2 3 5 1
5
//以上为第一组数据
5 2
1 3 3 3 1
2 3
//以上为第二组数据
样例输出:
5 found at 4
2 not found
3 found at 3

【分析】:这个题目的意思很清楚了,先排序在查找,我们可以利用c++中的algorithm头文件中的sort和lower_bound完成此题,代码如下:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#define maxn 10005
using namespace std;
int main()
{
    int t, n, a[maxn], c = 0, x;
    while (scanf("%d%d", &t, &n) == 2 && t)//本句话的意思是输入两个整形值,并且t不为0
    {
        for (int i = 0; i < t; i++)
        {
            scanf("%d", &a[i]);
        }
        sort(a, a + t);//排序
        while (n--)
        {
            scanf("%d", &x);
            int p = lower_bound(a, a + t, x) - a;//lower_bound(a,a+t,x)是在长度为t的数组a中寻找x,返回大于或者等于x的第一个位置
            if (a[p] == x)
                printf("%d is found at %d~~~~~~~~~~~~\n", x, p + 1);
            else
                printf("%d not found!!!!!!!!!!!!!!\n", x);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值