codeup|问题 E: FatMouse‘s Trade

题目描述
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

输出
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入 Copy
4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1
样例输出 Copy
2.286
2.500

代码

#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

struct warehouse {
    double J;//Javabean的数量
    double F;//总的需要的猫粮数
    double price;//一单位的猫粮能换多少数量的Javabean
} a[1000];

bool cmp(warehouse a, warehouse b) {
    return a.price > b.price;
}

int main() {
    double m;//double类型可以避免计算错误
    int n;
    while (scanf("%lf%d", &m, &n) && m != -1 && n != -1) {
        double sum = 0;//注意sum所处的位置
        for (int i = 0; i < n; i++) {
            scanf("%lf%lf", &a[i].J, &a[i].F);
            a[i].price = a[i].J / a[i].F;
        }
        sort(a, a + n, cmp);
        int j = 0;
        while (m - a[j].F >= 0) {
            m -= a[j].F;
            sum += a[j].J;
            j++;
        }
        if (m > 0) sum += a[j].price * m;
        printf("%.3lf\n", sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值