codeup|模拟加减乘除|问题 A: 简单计算器

题目描述
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入 Copy
30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0
样例输出 Copy
12178.21

代码

#include <stdio.h>
#include <iostream>
#include <string>

using namespace std;

void process(string str) {
    double n = 0.0;
    double num[200], st[200];
    char ch[200], st_ch[200];
    int step_n = 0, step_c = 0;
    char save = '0';

    for (int i = 0; i < str.size(); i++)//把数字和运算符统一拆出来,分别存入num,ch数组
    {
        if (str[i] >= '0' && str[i] <= '9') {
            n = n * 10 + str[i] - '0';
        } else if (str[i] != ' ') {
            num[step_n++] = n;
            n = 0.0;
            ch[step_c++] = str[i];
            i++;
        }
    }
    num[step_n] = n;//最后一个数字存入数组中
    st[0] = num[0];
    step_n = 0;
    for (int i = 0; i < step_c; i++) {
        if (ch[i] == '+' || ch[i] == '-') {
            st_ch[step_n++] = ch[i];
            st[step_n] = num[i + 1];
        } else {
            if (ch[i] == '*')
                st[step_n] *= num[i + 1];
            else
                st[step_n] /= num[i + 1];
        }
    }
    n = st[0];
    for (int i = 0; i < step_n; i++)//step_n为st数组中数字的个数
    {
        if (st_ch[i] == '+')
            n += st[i + 1];
        else
            n -= st[i + 1];
    }
    printf("%.2f\n", n);
}

int main() {
    string str;
    while (getline(cin, str), str != "0") {
        process(str);
    }
    return 0;
}

代码二

#include<iostream>
#include<stdio.h>
#include<string>
#include<map>
#include<stack>
#include<queue>

using namespace std;

struct node {
    double num;//操作数
    char op;//操作符
    bool flag;//flag为true表示操作数,flag为false表示操作符
};

string str;
stack<node> s;//操作符栈
queue<node> q;//后缀表达式序列
map<char, int> op;

void Change() {//将中缀表达式转换为后缀表达式
    double num;
    node temp;
    for (int i = 0; i < str.length(); ) {
        if (str[i] >= '0' && str[i] <= '9') {
            temp.flag = 1;
            temp.num = str[i++] - '0';
            while (i < str.length() && str[i] >= '0' && str[i] <= '9') {
                temp.num = temp.num * 10 + (str[i] - '0');//更新操作数
                i++;
            }
            q.push(temp);
        } else {
            temp.flag = false;//标记是操作符
            //只要操作符栈的栈顶元素比该操作符优先级高就把操作符栈顶元素弹出到后缀表达式的队列中
            while (!s.empty() && op[str[i]] <= op[s.top().op]) {
                q.push(s.top());
                s.pop();
            }
            temp.op = str[i];
            s.push(temp);//把该操作符压入操作符栈中
            i++;
        }
    }
    while (!s.empty()) {//如果操作符栈中还有操作符,就把它弹出到后缀表达式中
        q.push(s.top());
        s.pop();
    }
}

double Cal() {
    double temp1, temp2;
    node cur, temp;
    while (!q.empty()) {//只要后缀表达式队列非空
        cur = q.front();;//cur记录队首元素
        q.pop();
        if (cur.flag == true) s.push(cur);//当是操作数时直接压入栈中
        else {//当是操作符的情况
            temp2 = s.top().num;//弹出第二操作数
            s.pop();
            temp1 = s.top().num;//弹出第一操作数
            s.pop();
            temp.flag = true;//临时记录操作数
            if (cur.op == '+') temp.num = temp1 + temp2;
            else if (cur.op == '-') temp.num = temp1 - temp2;
            else if (cur.op == '*') temp.num = temp1 * temp2;
            else temp.num = temp1 / temp2;
            s.push(temp);
        }
    }
    return s.top().num;
}

int main() {
    op['+'] = op['-'] = 1;//设定操作符优先级
    op['*'] = op['/'] = 2;
    while (getline(cin, str), str != "0") {
        for (string::iterator it = str.end(); it != str.begin(); it--) {
            if (*it == ' ') str.erase(it);
        }
        while (!s.empty()) s.pop();
        Change();
        printf("%.2f\n", Cal());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值