1124 Raffle for Weibo Followers (20 分)

1124 Raffle for Weibo Followers (20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going…

AC代码(二刷)

#include <iostream>
#include <unordered_map>
#include <string>
#include <vector>
using namespace std;
int main(){
    int m, n, s;
    cin >> m >> n >> s;
    if (s > m){
        cout << "Keep going..." << endl;
        return 0;
    }
    vector<string> v(m+1);
    unordered_map<string, bool> mp;
    for (int i = 1; i <= m; i++) cin >> v[i];
    for (int i = s; i <= m; i+=n){
        if (mp[v[i]] == false){
            cout << v[i] << endl;
            mp[v[i]] = true;
        }
        else {
            while (mp[v[i]] == true){
                i++;
                if (i > m) return 0;
            }
            cout << v[i] << endl;
        }
    }
    return 0;
}

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main() {
	char Person[1001][21];
	int cnt = 0, k = 0;
	int M, N, S;	//转发的总量 中奖间隔 第一位中奖者的序号
	cin >> M >> N >> S;
	for (int i = 1; i <= M; i++) scanf("%s", Person[i]);	//得到转发人的昵称
	int Lucky[1001] = { 0 };
	if (S > M) { printf("Keep going...\n"); return 0; }	//第一位中奖者超出总人数
	printf("%s\n", Person[S]);
	Lucky[k++] = S;		//得到第一位中奖者 标记其已中过奖
	if (N + S > M) return 0;	//如果下位中奖者超出总人数
	for (int i = S+1; i <= M; i++) {
		cnt++;
		if (cnt == N) {
			int flag = 1;
			for (int j = 0; j < k; j++)		//如果此人已领过奖
				if (strcmp(Person[i], Person[Lucky[j]]) == 0) { flag = 0; break; }
			if (flag) {
				Lucky[k++] = i;		//标记其已中过奖
				printf("%s\n", Person[i]);
				cnt = 0;	//重新计数
			}
			else cnt--;		//已领过奖的人作废 不做计数
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值