1016 部分A+B (15 分)

1016 部分A+B (15 分)

在这里插入图片描述
输入样例 1:
3862767 6 13530293 3
输出样例 1:
399
输入样例 2:
3862767 1 13530293 8
输出样例 2:
0

AC代码

#include <iostream>
#include <string>
using namespace std;
int SumAandB(string strA, int DA, string strB, int DB);
int main(){
    string strA, strB;
    int DA, DB;
    cin >> strA >> DA >> strB >> DB;
    cout << SumAandB(strA, DA, strB, DB);
}
int SumAandB(string strA, int DA, string strB, int DB){
    int SumA = 0, SumB = 0;
    for (int i = 0; i < strA.size(); i++)
        if ((strA[i]-'0') == DA) SumA = SumA*10 + DA;
    for (int i = 0; i < strB.size(); i++)
        if ((strB[i]-'0') == DB) SumB = SumB*10 + DB;
    return SumA+SumB;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值