PAT A1040Longest Symmetric String

Description:

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

思路:

最大回文子串问题。回文串(palindromic string)是指这个字符串无论从左读还是从右读,所读的顺序是一样的;简而言之,回文串是左右对称的。

AC代码

#include <stdio.h>
#include <string.h>
#define maxn 1010 //最大子串长度为1000



int main()
{
    char s[maxn];
    int dp[maxn][maxn]={0};// dp[i][j]表示从i到j的字符串是否为回文子串,0表不是,1表是
    gets(s);//空格也吸收
    int len=strlen(s);//记录字符串长度
    int ans=1;//记录最大长度
    for(int i=0;i<len;i++)
    {
        dp[i][i]=1;
        if(i<len-1&&s[i]==s[i+1])
        {
            dp[i][i+1]=1;
            ans=2;
        }
    }//初始化长度为1和2的回文串
    for(int L=3;L<=len;L++)//枚举长度为3到len的子串
    {
        for(int j=0;j+L-1<len;j++)//考察[j,j+L-1]的长度为L的子串是否为回文串
        {
            if(s[j]==s[j+L-1]&&dp[j+1][j+L-2]==1)//状态转移
            {
                dp[j][j+L-1]=1;
                ans=L;
            }
        }
    }
    printf("%d",ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值