CCF NOI1066. 素数对 (C++)

80 篇文章 6 订阅

1066. 素数对

题目描述

两个相差为2的素数称为素数对,如5和7,17和19等,本题目要求找出所有两个数均不大于n的素数对。

输入

一个正整数n。1<=n<=10000。

输出

按照从小到大的顺序输出所有小于等于n的素数对。每对素数对输出一行,中间用单个空格隔开。若没有找到任何素数对,输出empty。

样例输入

100

样例输出

3 5
5 7
11 13
17 19
29 31
41 43
59 61
71 73

数据范围限制

1<=n<=10000。

C++代码

#include <iostream>
#include <cassert>
#include <cmath>

using namespace std;

bool checkPrime(int n)
{
    if (n <= 1 || n!=2 && n%2==0)
    {
        return false;
    }
    
    for(int i=3; i<=(int)sqrt(double(n)); i++)
    {
        if (n%i == 0)
        {
            return false;
        }
    }

    return true;
}


int main()
{
    const int max_n = 10000;
    int primeList[max_n];
    int n;

    cin >> n;

    assert(n>=1 && n<=max_n);

    for(int i=2; i<=n; i++)
    {
        if (true == checkPrime(i))
        {
            primeList[i] = 1;
        }
        else
        {
            primeList[i] = 0;
        }
    }

    bool primes_pair_found = false;

    for(int i=2; i<=n-2; i++)
    {
        if (primeList[i] == 1 && primeList[i+2] == 1)
        {
            cout << i << " " << i+2 << endl;
            primes_pair_found = true;
        }
    }

    if (false == primes_pair_found)
    {
        cout << "empty" << endl;
    }

    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值