PAT B1079

1079 延迟的回文数 (20 分)

给定一个 k+1 位的正整数 N,写成 a​k​​⋯a​1​​a​0​​ 的形式,其中对所有 i 有 0≤a​i​​<10 且 a​k​​>0。N 被称为一个回文数,当且仅当对所有 i 有 a​i​​=a​k−i​​。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number )

给定任意一个正整数,本题要求你找到其变出的那个回文数。
输入格式:

输入在一行中给出一个不超过1000位的正整数。
输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下

A + B = C

其中 A 是原始的数字,B 是 A 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.。
输入样例 1:

97152

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

输入样例 2:

196

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

第一次提交,最后一个测试点不过:

(超过int或 long int表示范围, 需要用数组处理)

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int check(string arr);
int main(){
	string str, copy;
	cin >> str;
	copy = str;
	int cnt = 0;
	reverse(copy.begin(), copy.end());
	while(check(str) == 0 && cnt < 10){
		int sum = 0;
		int len = str.size();
		cout << str << " + " << copy << " = ";
		for(int i = 0; i < len; i++) 
		sum = sum * 10 + str[i] - '0' + copy[i] - '0';
		cout << sum << endl;
		str.clear();
		for(int i = 0; sum != 0; i++){
			char ch = '0' + sum % 10;
			str += ch;
			sum /= 10;
		}
		copy = str;
		reverse(str.begin(), str.end());
		cnt++;
	}
	if(cnt < 10) cout << str << " is a palindromic number." << endl;
	else cout << "Not found in 10 iterations." << endl;
	 
} 
int check(string arr){
	int len = arr.size();
	for(int i = 0; i < len / 2; i++){
		if(arr[i] != arr[len - 1 - i])
		return 0;
	}
	return 1;
}

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int check(string arr);
int main(){
	string str, copy, ans;
	char ch;
	cin >> str;
	copy = str;
	int sum, cnt = 0;
	reverse(copy.begin(), copy.end());
	while(check(str) == 0 && cnt < 10){
		int len = str.size();
		cout << str << " + " << copy << " = ";
		int carry = 0;
		for(int i = len - 1; i >= 0; i--) {
			sum = str[i] - '0' + copy[i] - '0' + carry;
			ch =  sum % 10 + '0';
			ans += ch;
			carry = sum / 10;
		}
		if(carry != 0) ans += "1"; 
		copy = ans;
		str = copy;
		reverse(str.begin(), str.end());
		cout << str << endl;
		cnt++;
		ans.clear(); //出错点,使用后忘记清零,搞笑的是以为自己把这句写上了,在其他地方找错误找到抓狂
	}
	if(cnt < 10) cout << str << " is a palindromic number.";
	else cout << "Not found in 10 iterations.";
	 
} 
int check(string arr){
	int len = arr.size();
	for(int i = 0; i < len / 2; i++){
		if(arr[i] != arr[len - 1 - i])
		return 0;
	}
	return 1;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值