HDU-1102 Constructing Roads (最小生成树+并查集)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31254    Accepted Submission(s): 11800


 

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

 

 

Sample Input

 

3 0 990 692 990 0 179 692 179 0 1 1 2

 

 

Sample Output

 

179

AC代码:

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int MAX = 105;
int G[MAX][MAX], ans = 0;
struct node{
    int u, v, w;
    bool operator < (const node a) const{
        return w < a.w;
    }
};
vector<node> V;
int Pre[MAX];

int find(int a){
    int c = a;
    while(a != Pre[a])
        a = Pre[a];
    Pre[c] = a;
    return a;
}
bool join(int u, int v){
    int fu = find(u), fv = find(v);
    if(fu != fv){
        Pre[fv] = fu;
        return true;
    }
    return false;
}
void solve(){
    for(int i = 0; i < V.size(); i++)
        //利用并查集,如果连通成功,这个边的权值计入答案
        if(join(V[i].u, V[i].v)) ans += V[i].w;
    printf("%d\n",ans);
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        //初始化
        V.clear();
        ans=0;
        for(int i = 1; i <= n; i++) Pre[i] = i;
        //建图
        for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
            scanf("%d",&(G[i][j]));
        int k;scanf("%d",&k);
        while(k--){//把已经连同的村庄 w 设置为0
            int x,y;scanf("%d%d",&x,&y);
            G[x][y] = G[y][x] = 0;
        }
        //图中很多数据多余,只要右上三角的值就可以
        for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++){
            if(j > i){
                node a;
                a.u = i,a.v = j, a.w = G[i][j];
                V.push_back(a);
            }
        }
        //Kruskal算法,按边的权值排序,然后依次连同
        sort(V.begin(), V.end());
        solve();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值