Constructing Roads--prim最小生成树,并查集

题目

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意

有n个村庄,其中有一些村庄之间的道路已经建好,有些还没建,然后给你q个信息,每行输入a,b,d,表示a和b之间已经建好了一条话费为d的路。现在需要你再建一些路,让这n个村庄之间可以互相到达,但不一定是之间相连。

分析

最小生成树,本题用prim算法。如果两个村庄之间已经修好了路,那么就将这两个村庄合并到同一个集合当中,题目给的信息将这n个村庄分成了几个不同的集合。在prim算法中,从1到n遍历,如果发现 i 的根与1的根相同,就让mini=0,u=i,跳出循环。如果不相等,找到距离1所在集合最近的点,记下距离和下标。vis[u]=1,ans+=mini。更新其他点到1所在集合的距离。

知识点

并查集、prim最小生成树

代码

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
#define inf 0x3f3f3f
int n,q,ans,pre[105];
int mp[105][105];
int dis[105];
bool vis[105];
void init()
{
	for(int i=0;i<105;i++)
		pre[i]=i;
	memset(mp,inf,sizeof(inf));
}
int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int tmp,a=x;
	while(a!=r)
	{
		tmp=pre[a];
		pre[a]=r;
		a=tmp;
	}
	return r;
}
void unionn(int x,int y)
{
	pre[find(y)]=find(x);
}
void prim()
{
	ans=0;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)//1到其他点的距离  
		dis[i]=mp[1][i];
	vis[1]=1;	//不要忘了先将1标记 
	for(int k=1;k<n;k++)
	{
		int mini=inf,u;
		for(int i=1;i<=n;i++)
		{
			if(vis[i])
				continue;
			if(find(i)==find(1))//在同一个集合中  
			{
				mini=0;//mini=0表示不用修建道路  
				u=i;
				break;
			}
			if(dis[i]<mini)//找到距离集合最近的点  
			{
				mini=dis[i];
				u=i;
			}
		}
		vis[u]=1;//标记  
		ans += mini;//距离加和  
		unionn(u,1);//选择了,就得跟1合并  
		for(int i=1;i<=n;i++)
		{
			if(dis[i]>mp[u][i])//更新其他点到集合的距离  
				dis[i]=mp[u][i];
		}
	}
}
int main()
{
	while(cin>>n)
	{
		init();
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
				cin>>mp[i][j];
		}
		cin>>q;
		for(int i=0;i<q;i++)
		{
			int a,b;
			cin>>a>>b;
			int r1=find(a);
			int r2=find(b);
			if(r1!=r2)
				unionn(a,b);
		}
		prim();
		cout<<ans<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值