HDOJ-1040 As Easy As A+B

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80266 Accepted Submission(s): 34137

Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output
For each case, print the sorting result, and one line one case.

Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output
1 2 3
1 2 3 4 5 6 7 8 9

解题思路:数据量大,适合使用快速排序算法,降低时间复杂度

#include<iostream>
#include<cstdio>
using namespace std;

int a[1010]; //数组中存放整数 
void quicksort(int left,int right)//快速排序算法,可详见《啊哈!算法》快速排序章节 
{
    int i,j,t,temp;//整数按从小到大排序 
    if(left>right)
       return;  
    
    temp=a[left];//把数组的第一个数设为基准数 
    i=left;
    j=right;
    while(i!=j)  
    {
        while(a[j]>=temp&&i<j)//先从右开始,很重要,很重要,很重要 
           j--;     //如果遇到比基准数小的数就停下来 
        while(a[i]<=temp&&i<j)   //从左边开始 
           i++;  //遇到比基准数大的数就停下来 
        
        if(i<j)   //交换两个数的位置 
        {
            t=a[i];
            a[i]=a[j];
            a[j]=t; 
        }
    }
    //基准数归位
    a[left]=a[i];   
    a[i]=temp;
    
    quicksort(left,i-1);  //函数的递归调用 
    quicksort(i+1,right);
    return;    //至此,数组中的数从小到大排序完成 
 } 
 
 int main()
 {
     int i,T,N;
     cin>>T;  //有T个样例 
     while(T--)
     {
         cin>>N; 
         for(i=1;i<=N;i++)
            cin>>a[i];
         quicksort(1,N);  //数组元素排序 
         for(i=1;i<N;i++)
            cout<<a[i]<<" ";//先输出N-1个数,每个数后面有一个空格 
         cout<<a[i]<<endl; //在输出最后一个数,后面没有空格,然后换行,此处容易产生Presentation Error          
     }
     return 0;
 }
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值