expanding rod(二分+数学公式)

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000
在这里插入图片描述
题意:小棍受热膨胀变长,弯曲,求小棍中点上升的高度。
题解:这里需要用到弧长公式,三角函数,以及勾股定理。设原始长度、温度变化,膨胀系数分别为l,n,c;膨胀后的长度为L=(1+nc)l;高度变化为h;弧长半径为r;
在这里插入图片描述
根据勾股定理 :(r-h)
(r-h)+(l/2)
(l/2)=rr 化简得 r=(ll+4hh)/8/h;
弧长的一半对应得弧度为arcsin(l/2/r);
弧长就是2rarcsin(l/2/r);
然后二分高度。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const double eps=1e-5;
double l,n,c,L;
bool judge(double x){
    double r=(l*l+4*x*x)/8/x;
    double s=2*r*asin(l/2/r);
    return s>=L;

}
int main(){

    while(~scanf("%lf%lf%lf",&l,&n,&c)&&(l>=0||n>=0||c>=0)){
    L=(1+n*c)*l;
    double left=0,right=l/2,mid;
    while(right-left>eps){
        mid=(right+left)/2;
        if(judge(mid)) right=mid;
        else left=mid;

    }
    printf("%.3f\n",right);}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

轩辕青山

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值