STL-V解题报告

题目:
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, …
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n’th ugly number.
Input:
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
Output:
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
Sample Input:
1
2
9
0
Sample Output:
1
2
10
题义:定义“丑数”,是素数因子只有2或3或5的数,输出第n个“丑数”。
题解1:
我的思路是写两个函数,一个用来判断是否是素数,一个用来判断是否是“丑数”,其中“丑数”里面使用了素数函数。从1开始判断是否是素数,但这种方法运算量很大,容易超时。

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<vector>
#include<iomanip>
using namespace std;
bool sushu(int n)
{
    if(n==1)
        return false;
    for(int i=2;i<=sqrt(n);i++)
    {
        if(n%i==0)
            return false;
    }
    return true;
}
bool ugly(int n)
{
    int m=1;
    int a[1501];
    memset(a,0,sizeof(a));
    if(n==1)
        return true;
    if(n>1)
    {
        for(int i=2;i<=n;i++)
        {
            if(n%i==0&&sushu(i)&&i!=2&&i!=3&&i!=5)
            {
                    return false;
            }
        }
        return true;
    }
}
int main()
{
    int n,m;
    int a[1501];
    memset(a,0,sizeof(a));
    while(cin>>n)
    {
        if(n==0)
            break;
        m=1;
        for(int i=1;;i++)
        {
            if(ugly(i))
            {
                a[m]=i;
                m++;
            }
            if(m==n+1)
                break;
        }
        cout<<a[n]<<endl;
    }
    return 0;
}

题解2:
这个思路是在我的代码超时之后参空了网上的代码。使用打表储存,即从第一个丑数开始存到一个数组里,输出第n项。即先将1单出来,从2开始,判断2a,3b,5*c的大小,从小到大排列,排过之后的数的个数加一,知道n=1500打表结束。

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<vector>
#include<iomanip>
using namespace std;
int s[1501]={0,1};
int main()
{
    int x2=1,x3=1,x5=1,n;
    for (int i=2; i<1501; i++)
    {
        s[i] = min(s[x2]*2,min(s[x3]*3,s[x5]*5));
        if (s[i]==s[x2]*2)
             x2++;
        if (s[i]==s[x3]*3)
             x3++;
        if (s[i]==s[x5]*5)
             x5++;
    }
    while(cin>>n)
    {
        if(n==0)
            break;
        cout<<s[n]<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值