1032 挖掘机技术哪家强

在这里插入图片描述

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=100010;
struct test{
	int id;
	int score;
}t1[maxn];
bool cmp(test a,test b){
	return a.score>b.score;
}
int main(){
	int n,id,score;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>id>>score;
		t1[id].id=id;
		t1[id].score+=score;	
	}
	sort(t1+1,t1+n,cmp);
	cout<<t1[1].id<<" "<<t1[1].score<<endl;
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值