1081 检查密码

在这里插入图片描述

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
#include<string>
#include<iostream>
using namespace std;
int main(){
	int n;
	string str;
	cin>>n;
    getchar();
	while(n--){
		getline(cin,str);
		int num=0,word=0,count=0;
		int len=str.size();
		if(len<6||len>80){
			cout<<"Your password is tai duan le."<<endl;
            continue;
		}
		if(len>=6&&len<=80){
			for(int i=0;i<len;i++){
				if(str[i]>='0'&&str[i]<='9'){
					num++;
					continue;
				}
				if((str[i]>='A'&&str[i]<='Z')||(str[i]>='a'&&str[i]<='z')){
					word++;
					continue;
				}
				if(str[i]=='.'){
					continue;
				}
				else{
					count++;
					cout<<"Your password is tai luan le."<<endl;
					break;
				}
			}
		}
		if(count!=0) continue;
		if(num>0&&word>0){
			cout<<"Your password is wan mei."<<endl;
			continue;
		}
		if(num>0&&word==0){
			cout<<"Your password needs zi mu."<<endl;
			continue;
		}
		if(num==0&&word>0){
			cout<<"Your password needs shu zi."<<endl;
			continue;	
		}
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值