问题 N: 二叉树的创建和文本显示
编一个程序,读入先序遍历字符串,根据此字符串建立一棵二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
A ST C # # D 10 # G # # F # # #
各结点数据(长度不超过3),用空格分开,其中“#”代表空树。
建立起此二叉树以后,再按要求输出二叉树。
输入
输入由多组测试数据组成。
每组数据包含一行字符串,即二叉树的先序遍历,字符串长度大于0且不超过100。
输出
对于每组数据,显示对应的二叉树,然后再输出一空行。输出形式相当于常规树形左旋90度。见样例。 注意二叉树的每一层缩进为4,每一行行尾没有空格符号。
样例输入
A ST C # # D 10 # G # # F # # #
4 2 1 # # 3 # # 5 # 6 # #
样例输出
A
F
D
G
10
ST
C
6
5
4
3
2
1
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct BiNode
{
char data[5];
struct BiNode *lchild,*rchild;
}BiNode,*Bitree;
int m = 0;
Bitree G;
char b[101][5];
Bitree CreateBItree( Bitree G ) //建立二叉链表
{
if( b[m][0] == '#' ) { G = NULL; m++; }
else
{
G = (Bitree)malloc(sizeof(struct BiNode));
strcpy( G->data , b[m++] );
G->lchild = CreateBItree( G->lchild );
G->rchild = CreateBItree( G->rchild );
}
return G;
}
void INorder( Bitree G , int depth )
{
if( G != NULL )
{
INorder( G->rchild , depth + 1 );
int n = depth * 4;
while( n )
{
printf(" ");
n--;
}
printf("%s\n",G->data);
INorder( G->lchild , depth + 1 );
}
}
int main()
{
char a[1000];
while( gets( a ) != NULL )
{
int p = 0 , i, q = 0;
for( i = 0; a[i] != '\0'; i++ )
{
if( a[i] != ' ' )
b[p][q++] = a[i];
else
{
b[p++][q++] = '\0';
q = 0;
}
}
b[p++][q++] = '\0'; //将字符串分离出来
G = CreateBItree( G ); //建树,把数组所得的字符串存入树中;
INorder( G , 0 );
printf("\n");
m = 0;
}
return 0;
}
这一部分是关键,但是我不知道是怎么成功输出的,借鉴了别人的代码
void INorder( Bitree G , int depth )
{
if( G != NULL )
{
INorder( G->rchild , depth + 1 );
int n = depth * 4;
while( n )
{
printf(" ");
n--;
}
printf("%s\n",G->data);
INorder( G->lchild , depth + 1 );
}
}