Pop Sequence

Given a stack which can keep M M M numbers at most. Push N N N numbers in the order of 1 , 2 , 3 , . . . , N 1, 2, 3, ..., N 1,2,3,...,N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M M M is 5 5 5 and N is 7 7 7, we can obtain 1 , 2 , 3 , 4 , 5 , 6 , 7 1, 2, 3, 4, 5, 6, 7 1,2,3,4,5,6,7 from the stack, but not 3 , 2 , 1 , 7 , 5 , 6 , 4 3, 2, 1, 7, 5, 6, 4 3,2,1,7,5,6,4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 3 3 numbers (all no more than 1000 1000 1000): M M M (the maximum capacity of the stack), N N N (the length of push sequence), and K K K (the number of pop sequences to be checked). Then K K K lines follow, each contains a pop sequence of N N N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <bits/stdc++.h>

using namespace std;

int main() {
    int n, m, k;
    scanf("%d%d%d", &n, &m, &k);
    for (int i = 0; i < k; i++) {
        int p = 1;
        bool flag = true;
        stack<int> s;
        for (int j = 0, tmp; j < m; j++) {
            scanf("%d", &tmp);
            while (p <= tmp) {
                s.push(p);
                if (s.size() > n) {
                    flag = false;
                    break;
                }
                p++;
            }
            if (s.top() != tmp) {
                flag = false;
                continue;
            }
            s.pop();
        }
        if (flag) puts("YES"); else puts("NO");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值