Bone Collector

传送门

题面:

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 92471
Accepted Submission(s): 37824

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题面描述:

给出每种骨头的价值和大小,再给出背包的大小,要求把骨头装进背包所得的最大价值的方法。

题目分析:

01背包问题:每种物品有两个选择,放或者不放,主要看状态转移方程。

代码:

#include<algorithm>
#include<stdio.h> 
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int t,n,v,i,j,pm[1005],pa[1005],dp[1005][1005];
//#define max(a,b) (a)>(b)?(a):(b)//宏定义 

int main(){
	cin>>t;
	while(t--){
		memset(dp,0,sizeof(dp));
		cin>>n>>v;
		for(i=1;i<=n;i++) cin>>pa[i];
		for(i=1;i<=n;i++) cin>>pm[i];
		for(i=1;i<=n;i++){//物品个数循环 
			for(j=0;j<=v;j++){//背包大小从0到最大,可能有体积为0的物体 
				if(j>=pm[i]) dp[i][j]=max(dp[i-1][j],dp[i-1][j-pm[i]]+pa[i]);//状态转移:不放i时最大价值与放i时最大价值比较 
				else dp[i][j]=dp[i-1][j];
			}
		}
		printf("%d\n",dp[n][v]);
	}
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值