解题报告:POJ1401(数学思想计算阶乘得数0的个数)

POJ1401(数学思想计算阶乘得数0的个数)

题目地址—>http://poj.org/problem?id=1401

原题

Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4…N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never “lose” any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837

题目大意

本题是给我们一个数字,让我们计算这个数字的阶乘得数末尾一共有多少个0。

解题思路

我们根据数学思想,要得到0必须有数字和10相乘,进而求知25=10,就是去计算25的匹配次数,由于随便给一串数字,比如10的阶乘:1 2 3 4 5 6 7 8 9 10,将每个数分解可得有8个2,2个5,因此我们知道数字的阶乘中分解出来2的个数肯定要比5的个数要多得多,那么要求匹配对数,就是让我们去求分解出来之后5的个数,具体实现请看代码。

源代码

#include<iostream>
using namespace std;

int GetSum(int flag,int &sum)
{
	if(flag==0)
		return sum;
	else
	{
		while(flag>0)
		{
			sum=sum+flag/5;//第一步计算有多少个5
			flag=flag/5;
		}
		return GetSum(flag,sum);
	}
}

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int m,sum=0;
		cin>>m;
		cout<<GetSum(m,sum)<<endl;
	}
	return 0;
}
//可以不用递归,本人强迫症
//欢迎讨论
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值