E - Digit Generator UVA - 1583

English!!English!!English Description!!Do it!!
For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1$ \le N N N \le$100, 000 .

Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

题目链接 UVA - 1583
题意:略。

有两种解法。
解法一:思路为遍历比N小的数。所求数一定大于N减去它的位数乘9,故从这个数开始遍历。
代码:

#include <iostream>
#include <cmath>

using namespace std;

int main(){
	int t,n;
	cin>>t;
	while(t--){
		cin>>n;
		int cnt = 0;
		int m = n;
		while(m){
			m /= 10;
			cnt++;
		}
		//cout<<cnt<<endl;
		int sum;
		int i = n - cnt * 9;
		//cout<<i<<endl;
		for(;i<n;i++){
			sum = i;
			int j = i;
		
			while(j){
				sum += j % 10;
				j /= 10;
			}
			if(sum == n)
				break;
		}
		if(i <= n - 1)
			cout<<i<<endl;
		else
			cout<<0<<endl;
	}
	return 0;
}

解法二:打表。
代码:

#include <iostream>
#include <cstring>

using namespace std;

const int N = 1e5;

int main(){
	int ans[N + 1],t,n;
	memset(ans,0,sizeof(ans));
	for(int i=1;i<N;i++){
		int sum = i;
		int k = i;
		while(k){
			sum += k % 10;
			k /= 10;
		}
		if(sum <= N){
			if(!ans[sum])
				ans[sum] = i;
		}
	}
	
	cin>>t;
	while(t--){
		cin>>n;
		cout<<ans[n]<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值