每日一(+1)道算法题 Day5 of PAT 1006 Sign In and Sign Out (25分)

1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

这道题,不难,简而言之,就是给你每个人出入公司的时间,给他们排个序,输出最早来和最晚走的人的工号,就这么简单!

Attention:

  • 不要看到这种时间格式,就想用Split函数来进行字符串的拆解,一方面是,c++没有已经写好的SPlit函数,自己写又麻烦,另一方面,这道题也完全没有Split的必要啊,比较时间,直接用strcmp来比较就是了
  • 至于排序,duck不必自己写,虽然是结构体存储方式,但我们可以通过sort函数以及重写比较函数来实现我们的目的,排序过程也不用我们操心,效率也很高,何乐而不为呢
  • 输出上面,老调重弹,最后不要有空格

Details:

鉴于时间格式、长度都已确定,那么存储时就直接用定长的char数组好了,免得出现各种问题

然后就是,切记,在C++里面,字符串的赋值和比较都要用函数进行操作,否则就会因为字符串的指针本质导致传了地址而不是传值,导致数据混乱

Code:

#include <bits/stdc++.h>
using namespace std;
typedef struct timeInfo{
	string id;
	char* inTime=(char*)malloc(8*sizeof(char));
	char* outTime=(char*)malloc(8*sizeof(char));
}timeInfo;
void InitTimeInfo(timeInfo &tI, string a, char* b, char* c){
	tI.id=a;
	strcpy(tI.inTime,b);
	strcpy(tI.outTime,c);
}
bool cmpInTime(timeInfo a, timeInfo b){
	return (strcmp(a.inTime,b.inTime)<0);
}
bool cmpOutTime(timeInfo a, timeInfo b){
	return (strcmp(a.inTime,b.inTime)>0);
}
int main(){
	int num;
	cin>>num;
	vector<timeInfo> timeVec;
	for(int i=0;i<num;i++){
		string id;
		char inTime[8];
		char outTime[8];
		cin>>id>>inTime>>outTime;
		timeInfo tI;
		InitTimeInfo(tI, id, inTime, outTime);
		timeVec.push_back(tI); 
	}
	sort(timeVec.begin(),timeVec.end(),cmpInTime);
	cout<<timeVec[0].id;
	cout<<" "; 
	sort(timeVec.begin(),timeVec.end(),cmpOutTime);
	cout<<timeVec[0].id;
	return 0;
}

Summary and harvest

(for my current level)

Parameters

  • first, last
    Random-access iterators to the initial and final positions of the sequence to be sorted. The range used is [first,last), which contains all the elements between first and last, including the element pointed by first but not the element pointed by last.
    RandomAccessIterator shall point to a type for which swap is properly defined and which is both move-constructible and move-assignable.
  • comp
    Binary function that accepts two elements in the range as arguments, and returns a value convertible to bool. The value returned indicates whether the element passed as first argument is considered to go before the second in the specific strict weak ordering it defines.
    The function shall not modify any of its arguments.
    This can either be a function pointer or a function object.
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值