每日一道算法题 Day10 of PAT C++ 1011 World Cup Betting (20分)

1011 World Cup Betting (20分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31


今天白天刚写完《人月神话》的读书笔记,晚上就搞道小题来做做吧,拿到题,果然是小题,正合我意

这道题,是关于世界杯投注的,说得好听点叫做投注,不好听叫赌球,开头铺垫了一大套,还有不认识的单词,不认识没事。看人看眼睛、看问题抓重点,那么什么是重点?钱!!!!天下熙熙,皆为利来;天下攘攘,皆为利往。如此世界,抛却了圣人贤说这点精神追求,剩下那么点全给利占去了。

好,那么抓住重点,别单词不认识,profit,盈利总该认识吧,好了,这就抓住重点了,前后一看,无非就是三场比赛,每场比赛的每一种可能都有对应的赔率,三场比赛,找出每场比赛赔率最高的选择,按照公式算出profit,最后依次输出三场比赛赔率最大的选择,然后再输出profit的值,就收工了


Attention:

  • 注意输出精度为2,字母大写,无空格

Details:

三场比赛,每场比赛三种选择,要挑选最大值,那就3X3两重循环解决问题


Code:

#include <bits/stdc++.h>
using namespace std;
int main(){
	double value[3]={-100};
	int flag[3];
	char map[3]={'W','T','L'};
	
	for(int i=0;i<3;i++){
		double temp;
		for(int j=0;j<3;j++){
			cin>>temp;
			if(value[i]<temp){
				value[i]=temp;
				flag[i]=j;
			}
		}
	}
	double profit=(value[0]*value[1]*value[2]*0.65-1)*2;
	for(int i=0;i<3;i++){
		cout<<map[flag[i]]<<" ";
	}
	printf("%.2f", profit);
	return 0;
} 

Summary and harvest

(for my current level)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值