PAT19年春第三题Telefraud Detection (25 分)

Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.
A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.
Input Specification:
Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤103, the number of different phone numbers), and M (≤105, the number of phone call records). Then M lines of one day’s records are given, each in the format:
caller receiver duration
where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.
Output Specification:
Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
If no one is detected, output None instead.
Sample Input 1:
5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1
Sample Output 1:
3 5
6
Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1 had made 5 short phone calls and didn’t exceed the threshold 5, and therefore is not a suspect.
Sample Input 2:
5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1
Sample Output 2:
None

#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
int call[1010][1010]={0};
int father[1010];
int findfather(int x)
{
    int a=x;
    while(x!=father[x])
        x=father[x];
    while(a!=father[a])
    {
        int z=a;
        a=father[a];
        father[z]=x;
    }
    return x;
}
void Union(int a,int b)
{
    int faa=findfather(a);
    int fab=findfather(b);
    if(faa!=fab)
    {
        if(faa>fab)
            swap(faa,fab);
        father[fab]=faa;
    }
}
int main()
{
    int k,n,m,c,r,d;
    scanf("%d%d%d",&k,&n,&m);
    for(int i=1;i<=n;i++)
        father[i]=i;
    map<int,vector<int> > gangs;
    vector<int> suspects;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&c,&r,&d);
        call[c][r]+=d;
    }
    for(int i=1;i<=n;i++)
    {
        //统计i拨打的短电话以及回拨数
        int sum=0,rcall=0;
        for(int j=1;j<=n;j++)
        {
            if(call[i][j]>0&&call[i][j]<=5)
            {
                sum++;
                if(call[j][i]>0)
                    rcall++;
            }
        }
        //i打了超过k次短电话,且回拨次数少于总次数20%,将i列为嫌疑人
        if(sum>k&&1.0*rcall/sum<=0.2)
            suspects.push_back(i);
    }
    for(int i=0;i<suspects.size();i++)
    {
        for(int j=i;j<suspects.size();j++)
        {
            //若2名嫌疑人之间互相有通话,将2人聚合
            if(call[suspects[i]][suspects[j]]>0&&call[suspects[j]][suspects[i]]>0)
                Union(suspects[i],suspects[j]);
        }
    }
    //确定每个团伙的头目
    for(int i=0;i<suspects.size();i++)
    {
        int leader=findfather(suspects[i]);
        gangs[leader].push_back(suspects[i]);
    }
    if(gangs.empty())
        printf("None\n");
    else
    {
        for(int i=0;i<gangs.size();i++)
        {
            sort(gangs[i].begin(),gangs[i].end());
            for(int j=0;j<gangs[i].size();j++)
                printf("%d%s",gangs[i][j],j==gangs[i].size()-1?"\n":" ");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值