Wormholes POJ - 3259(spfa / Bellman-ford判断负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:先给一个正权值双向图,然后给一些有向路径,权值为负(题目的意思是虫洞可以从一个地方回溯它的权值这么多,那么相当于权值为负),问是否存在负环(从一个地方出发,在路径和<=0的情况下回到原来的点)

思路:判断负环模板题,Bellman-ford或者spfa都可以

Bellman-ford做法:
#include<iostream>
#include<cstring>
#include<cstdio>
const int N = 10003;
using namespace std;
#define inf 0x3f3f3f3f
struct edge
{
	int a,b,c;
	edge(){}
	edge(int a,int b,int c):a(a),b(b),c(c){}
}edges[N];
int dis[N],tem[N];
int n,m;
bool bellman_ford()
{
	memset(dis,inf,sizeof dis);
	dis[1]=0;
	for(int i=0;i<n;i++)
	{
		memcpy(tem,dis,sizeof dis);
		
		for(int j=0;j<m;j++)
		{
			edge e=edges[j];
			dis[e.b]=min(dis[e.b],tem[e.a]+e.c);
		}
	}
	for(int i=0;i<m;i++)
	{
		edge e=edges[i];
		if(dis[e.b]>dis[e.a]+e.c)
			return false;
	}
	return true;
}
int main()
{
	int f,w;
	cin>>f;
	while(f--)
	{
		cin>>n>>m>>w;
		int k=0;
		for(int i=0;i<m;i++)
		{
			int a,b,c;
			cin>>a>>b>>c;
			edges[k++]={a,b,c};
			edges[k++]={b,a,c};
		}
		for(int i=0;i<w;i++)
		{
			int a,b,c;
			cin>>a>>b>>c;
			edges[k++]={a,b,-c};
		}
		m=k;
		if(!bellman_ford())
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}


spfa做法:
#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
int n,m;
const int N =1e4+10;
int e[N],ne[N],h[N],w[N],idx;
int d[N],dis[N],vis[N];
void add(int a,int b,int c)
{
    e[idx]=b,w[idx]=c,ne[idx]=h[a],h[a]=idx++;
}
void init()
{
    idx=0;memset(h,-1,sizeof h);
}
bool spfa()
{
	memset(d,0,sizeof d);
	memset(dis,0,sizeof dis);
	memset(vis,0,sizeof vis);
    queue<int> q;
    for(int i=1;i<=n;i++)
    {
        q.push(i);vis[i]=1;
    }
    while(q.size())
    {
        int x=q.front();q.pop();
        vis[x]=0;
        for(int i=h[x];i!=-1;i=ne[i])
        {
            int j=e[i];
            if(dis[j]>dis[x]+w[i])
            {
                dis[j]=dis[x]+w[i];
                d[j]=d[x]+1;
                if(d[j]>=n)
                    return true;
                if(!vis[j])
                {
                    q.push(j);vis[j]=1;
                }
            }
        }
    }
    return false;
}
int main()
{
	int f;
	cin>>f;
	while(f--)
	{
		init();
		int ww;
	    scanf("%d%d%d",&n,&m,&ww);
	    for(int i=0;i<m;i++)
	    {
	        int a,b,c;
	        scanf("%d%d%d",&a,&b,&c);
	        add(a,b,c);
	        add(b,a,c);
	    }
	    for(int i=0;i<ww;i++)
	    {
	        int a,b,c;
	        scanf("%d%d%d",&a,&b,&c);
	        add(a,b,-c);
	    }
	    if(spfa())
	        printf("YES\n");
	    else
	        printf("NO\n");
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值