An easy problem HDU - 5475 (暴力 / 线段树)

One day, a useless calculator was being built by Kuros. Let’s assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.

  1. multiply X with a number.
  2. divide X with a number which was multiplied before.
    After each operation, please output the number X modulo M.
    Input
    The first line is an integer T(1≤T≤10), indicating the number of test cases.
    For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤109)
    The next Q lines, each line starts with an integer x indicating the type of operation.
    if x is 1, an integer y is given, indicating the number to multiply. (0<y≤109)
    if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It’s guaranteed that in type 2 operation, there won’t be two same n.
Output
For each test case, the first line, please output “Case #x:” and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
Sample Input
1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7
Sample Output
Case #1:
2
1
2
20
10
1
6
42
504
84

题意:初始值为1,后面进行q此操作,每次读入两个数x和y,若x=1,那么输出前面计算后的结果乘上y的结果,否则的话,输出当前结果除以第y次操作的数的结果。(输出的都是模m的值)

思路:
1.暴力做法:第一次做的时候是暴力写的,暴力是o(n^2)的复杂度,理论上是过不了的,应该是数据水了。。这里暴力做法也贴一下。(因为除运算是不能一边模一边除的,所以每次碰见除法,将那次的操作标记一下,然后从第一次操作再乘过来(只乘未标记过的))

代码:

#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const int N =1e5+10;
int a[N],vis[N];
int main()
{
	int t,q,m,cas=1;
	cin>>t;
	ll ans=1;
	while(t--)
	{
		cin>>q>>m;
		ans=1;
		memset(vis,0,sizeof vis);
		printf("Case #%d:\n",cas++);
		for(int i=1;i<=q;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(x==1)
				a[i]=y,ans=ans*y%m;
			else 
			{
				ans=1;
				vis[i]=1;vis[y]=1;
				for(int j=1;j<i;j++)
				{
					if(!vis[j])
						ans=ans*a[j]%m;
				}
			}
			printf("%lld\n",ans);
		}		
	}
	return 0;
}

2.线段树做法:
单点更新,区间查询,每次输出根节点的值就可以了,碰见除法的时候,将那个节点的值更新为1

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N =1e5+10;
int mod;
typedef long long ll;
ll sum[N<<2];
void pushup(int x)
{
	sum[x]=sum[x<<1]*sum[x<<1|1]%mod;
}
void build(int x,int l,int r)
{
	sum[x]=1;
	if(l==r)
		return;
	int mid=l+r>>1;
	build(x<<1,l,mid);
	build(x<<1|1,mid+1,r);
}
void update(int x,int l,int r,int tem,int val)
{
	if(l==r)
	{
		sum[x]=val;
		return;
	}
	int mid=l+r>>1;
	if(tem<=mid)
		update(x<<1,l,mid,tem,val);
	else
		update(x<<1|1,mid+1,r,tem,val);
	pushup(x);
}
int main()
{
	int t,cas=1;
	cin>>t;
	while(t--)
	{
		int q;
		cin>>q>>mod;
		build(1,1,q);
		printf("Case #%d:\n",cas++);
		for(int i=1;i<=q;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			if(x==1)
			{
				update(1,1,q,i,y);
				printf("%lld\n",sum[1]);
			}
			else
			{
				update(1,1,q,y,1);
				printf("%lld\n",sum[1]);
			}
		}
	}
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值