UVA 11389 - The Bus Driver Problem (贪心算法涉及sort函数) ( H-8)


Root Submit Problem Stats
uDebug Download as PDF
11389 - The Bus Driver Problem

Time limit: 1.000 seconds

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes with
various lengths. Each driver is assigned one morning route and one evening route. For any driver, if
his total route length for a day exceeds d, he has to be paid overtime for every hour after the first d
hours at a flat r taka / hour. Your task is to assign one morning route and one evening route to each
bus driver so that the total overtime amount that the authority has to pay is minimized.
Input
The first line of each test case has three integers n, d and r, as described above. In the second line,
there are n space separated integers which are the lengths of the morning routes given in meters.
Similarly the third line has n space separated integers denoting the evening route lengths. The lengths
are positive integers less than or equal to 10000. The end of input is denoted by a case with three 0’s.
Output
For each test case, print the minimum possible overtime amount that the authority must pay.
Constraints
• 1 ≤ n ≤ 100
• 1 ≤ d ≤ 10000
• 1 ≤ r ≤ 5
Sample Input
2 20 5
10 15
10 15
2 20 5
10 10
10 10
0 0 0
Sample Output
50
0

分析:
这道题要求得是最少得需要支付的工资给司机时要怎么分配每个司机的两条路线,实际上就是使用贪心算法(背包问题其实也是贪心算法),那么到底要怎么选呢,我们就第一个例子来说,假如白天晚上都有两条路线,a1 > a2 , b1 < b2 (a1 , a2是白天的两条路的length;b1 ,b2是晚上的两条路的length),可以看一下AOQNRMGYXLMV的解释,里面把这三种情况都列出来了,那么得出的结果就是:早上最短的路配晚上最长的路这样得出的就是最少支付的啦,嘿嘿嘿。

代码实现:
输入后给早上和晚上的路线各自排序,一个由低到高,一个有高到低,利用到sort函数这样比较方便。

VJ通过的代码如下:

#include <iostream>
#include <algorithm>
using namespace std;
bool compare(int a, int b)//sort函数的比较方式是大到小
{
	return a > b;
}
int main()
{
    
	int n, d, r;
	while (cin>>n>>d>>r && n&&d&&r)
	{
        int a[110], b[110];
		int sum = 0;
		for (int i = 1;i <= n;i++)
			cin>>a[i];
		for (int i = 1;i <= n;i++)
			cin>>b[i];
		sort(a+1, a + n+1);
		sort(b+1, b + n+1, compare);
		for (int i = 1;i <= n;i++)
		{
			if (a[i] + b[i] > d)
				sum += (a[i] + b[i] - d)*r;
		}
		printf("%d\n", sum);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值