HDU-1312 - BFS与DFS做法

2 篇文章 0 订阅
2 篇文章 0 订阅

题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1312

Red and Black
Oil Deposits Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29121 Accepted Submission(s): 17622

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13


DFS做法:

#include <iostream>
using namespace std;

const int MAXN = 21;
char a[MAXN][MAXN];
int ans=0;
int m,n;
int x,y;

int d[4][2] = {{-1, 0}, {1, 0}, {0, 1}, {0, -1}};

void dfs(int x,int y)
{
    a[x][y]='#';                        //走过则标记为#
    ans++;
    int p, q;
    for (int i = 0; i < 4; i++)
    {
        p = x + d[i][0];
        q = y + d[i][1];
        if (p > 0 && q > 0 && p <= n && q <= m && a[p][q] == '.')    //对四个方向进行判断是否走过
        {
            dfs(p, q);                   //如果没走过则进行dfs递归
        }
    }
}

int main()
{
    while(cin >> m >> n && m && n)
    {
        ans = 0;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
            {
                cin >> a[i][j];
                if(a[i][j] == '@')
                {
                    x=i;
                    y=j;
                }
            }
            dfs(x,y);
        cout << ans << endl;
    }
    return 0;
}


BFS做法:

#include <queue>
using namespace std;
char mp[100][100];
int dir[4][2] = {-1,0,0,-1,1,0,0,1};      //方向
int n,m,ans;

#define CHECK(x, y) (x<m && x>=0 && y >=0 && y<n)     //判断是否越界

struct node                             //把坐标定义成结点
{
    int x,y;
};



void bfs(int dx,int dy)
{
    ans=1;
    queue <node> q;                        //bfs需要用到队列
    node start,next;                       //开两个结点
    start.x = dx;
    start.y = dy;

    q.push(start);                         //把第一个结点放入队列

    while(!q.empty())                       //当队列不为空时
    {
        start = q.front();                  //拿出队列的第一个元素
        q.pop();                            //删除队列里的第一个元素

        for(int i=0; i<4; i++)
        {
            next.x = start.x + dir[i][0];
            next.y = start.y + dir[i][1];
            if( CHECK(next.x,next.y) && mp[next.x][next.y]=='.')
            {
                mp[next.x][next.y] = '#';
                ans++;
                q.push(next);                //把下次走的四个方向放入队列
            }								//依次循环直至走完所以的点
        }
    }
}

int main()
{
    int x,y,dx,dy;
    while(cin >> m >> n && m && n)
    {

        for (y = 0; y < n; y++)
        {
            for (x = 0; x < m; x++)
            {
                cin >> mp[x][y];
                if(mp[x][y] == '@')
                {
                    dx = x;
                    dy = y;
                }
            }
        }
        ans=0;
        bfs(dx,dy);
        cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值