Week15 作业A - ZJM 与霍格沃兹

1.题意

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

2.样例

Input

首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

3.解题思路

  1. 字符串哈希,seed取质数7,mod取值1e9,为了防止溢出,边计算边取模
  2. 为了节省内存空间,使用map<hash,index>,s1[index]=翻译,s2[index]=英文
  3. 为了简化输入输出时的处理,计算英文map时带着[],而相应字符串存储时要去掉[]
  4. 一直报错output limit exceeded,一直看,发现在调试过程中多输出了一个s2,因为主要输出结果都在下面,所以一直没看出来,以为是写成了死循环
  5. 在使用C++进行编译时,报错getline找不到标识符,要加上头文件#include< string>

4.AC代码

#include<iostream>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
const long long mod=1e9+7;
vector<string>v1,v2;
map<long long,int>m1,m2;
long long mp(string s)
{
	long long tmp=0;
	for(int i=0;i<s.size();i++)
	{
		tmp=(tmp+(long long)(s[i])*7)%mod;
		tmp=tmp*7%mod;
	}
	return tmp;
}
int main()
{
	string str;
	while(getline(cin,str))
	{
		if(str=="@END@")	break;
		string s1="",s2="",s3="";
		bool flag=false;
		for(int i=0;i<str.size();i++)
		{
			if(str[i]!=']'&&flag==false) 
			{
				s1+=str[i];
				if(str[i]!='[')
				{
					s3+=str[i];
				}
			}
			if(str[i]==']') {
				s1+=str[i];
				flag=true;
				i=i+2;
			}
			if(flag==true) s2+=str[i];
		}
		long long h1=mp(s1);
		v1.push_back(s2);
		m1[h1]=v1.size()-1;
		long long h2=mp(s2);
		v2.push_back(s3);
		m2[h2]=v2.size()-1;
	}
	int n;
	cin>>n;
	getline(cin,str);
	while(n--)
	{
		getline(cin,str);
		long long tp=mp(str);
		if(str[0]=='[')
		{
			if(m1.find(tp)==m1.end()) cout<<"what?"<<endl;
			else cout<<v1[m1[tp]]<<endl;
		}
		else
		{
			if(m2.find(tp)==m2.end()) cout<<"what?"<<endl;
			else cout<<v2[m2[tp]]<<endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值