PAT 1093 Count PAT‘s

1093 Count PAT's (25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

 代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
 
const int MOD = 1000000007;
const int MAXN = 100010;
char str[MAXN];
int left_num_p[MAXN] = {0};

int main(){
	//gets(str);
    cin.getline(str,MAXN);
        
	int len = strlen(str);
	for(int i = 0 ; i < len ; i++){
		if(i > 0){
			left_num_p[i] = left_num_p[i-1];
		}
		if(str[i] == 'P'){
			left_num_p[i]++;
		}
	}
	
	int ans = 0,right_num_t = 0;
	for (int i = len - 1 ; i > -1; i--){
		if(str[i] == 'T'){
			right_num_t++;
		}else if(str[i] == 'A'){
			ans = (ans + left_num_p[i] * right_num_t) % MOD;
		}
	}
	printf("%d\n",ans);
	
	return 0;
}

总结:

           这一题直接暴力会超时,实现不难,难就难在递推的思路,而且在实现中要注意:PAT中已经不支持gets(),需要使用c++中的cin.getline()来进行替换——详见https://blog.csdn.net/weixin_43717253/article/details/115012411

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值