RIP实验(基于web iou)

RIP实验(基于web iou模拟器)

1.实验拓扑图

在这里插入图片描述

2.实验要求

1.R1为ISP,其上只能配置Ip地址,不得再进行其他配置
2.R7环回地址172.16.1.0/24
  R8环回地址172.16.2.0/24
  R7-R8之间地址为78.1.1.0/24
  剩余所有网路地址使用192.168.1.0/24
3.R2到R5环回通过R3访问
4.加快协议收敛速度,保证更新安全,尽量减少路由条目
5.R2-R8设备均可访问R1环回
6.R1 telnet R2实际登录到R8

3.实验规划

1.R7-R8之间使用第二地址解决不连续子网问题 (在R7,R8上配置)
2.R2访问R5走R6,在R6上使用偏移列表增加度量值 (在R6上配置)
3.R2,R3,R4,R5,R6环回做汇总,减少路由条目 (在R2,R3,R4,R5,R6上配置)
4.R3-R4做明文认证,R4-R5做密文认证 (在R3,R4,R5上配置)
5.加快收敛速度(在R2,R3,R4,R5,R6上配置)
6.V1-V2通信问题 (在R6,R7上配置)
7.访问外网 (在R2上配置)
8.远程登录(R2,R8上配置)

4.配置

(1).ISP
Router>enable
Router#configure terminal
Router(config)#hostname ISP
ISP(config)#no ip domain-lookup 
ISP(config)#line console 0
ISP(config-line)#logging synchronous
ISP(config-line)#exec-timeout 0 0
**ISP环回地址**
ISP(config-line)#exit
ISP(config)#interface loopback 0
ISP(config-if)#ip address 1.1.1.1 255.255.255.0
ISP(config-if)#exit 
**ISP-R2骨干地址**
ISP(config)#interface e1/0
ISP(config-if)#ip address 12.1.1.1 255.255.255.0
ISP(config-if)#no shutdown 
ISP(config-if)#exit 
(2).R2
Router>enable 
Router#configure terminal 
Router(config)#hostname R2
R2(config)#no ip domain-lookup 
R2(config)#line console 0
R2(config-line)#logging synchronous 
R2(config-line)#exec-timeout 0 0
R2(config-line)#exit 
**R2环回地址**
R2(config)#interface loopback 0
R2(config-if)#ip address 192.168.1.17 255.255.255.248
R2(config-if)#exit 
R2(config)#interface loopback 1
R2(config-if)#ip address 192.168.1.25 255.255.255.248
R2(config-if)#exit 
**R2-ISP骨干地址**
R2(config)#interface e1/1
R2(config-if)#ip address 12.1.1.2 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#exit 
**R2-R3骨干地址**
R2(config)#interface e1/0     
R2(config-if)#ip address 192.168.1.1 255.255.255.240
R2(config-if)#no shutdown 
R2(config-if)#exit 
**R2-R6骨干地址**
R2(config)#interface e0/1
R2(config-if)#ip address 192.168.1.162 255.255.255.224
R2(config-if)#no shutdown 
R2(config-if)#exit 
**RIP V2**
R2(config)#router rip  
R2(config-router)#version 2
R2(config-router)#no auto-summary 
R2(config-router)#network 192.168.1.0	
**减少路由条目,环回汇总**
R2(config)#interface e1/0
R2(config-if)#ip summary-address rip 192.168.1.16 255.255.255.240
R2(config-if)#exit 
R2(config)#interface e0/1
R2(config-if)#ip summary-address rip 192.168.1.16 255.255.255.240
R2(config-if)#exit 
**加快收敛速度**
R2(config)#router rip 
R2(config-router)#timers basic 15 90 90 120
R2(config-router)#exit 
**访问外网**
(1).定义内外网
R2(config)#interface e1/1
R2(config-if)#ip nat outside 
R2(config-if)#exit 
R2(config)#interface e0/1
R2(config-if)#ip nat inside 
R2(config)#interface e1/0
R2(config-if)#ip nat inside
R2(config-if)#exit  
(3).缺省指向外网
R2(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.1
R2(config)#router rip 
R2(config-router)#default-information originate 
(2).ACL控制列表
R2(config)#access-list 1 permit any 
R2(config)#ip nat inside source list 1 interface e1/1
**远程登录转换**
R2(config)#ip nat inside source static tcp 78.1.1.2 23 12.1.1.2 23   
(3).R3
Router>enable
Router#configure terminal  
Router(config)#hostname R3
R3(config)#no ip domain-lookup 
R3(config)#line console 0
R3(config-line)#logging synchronous 
R3(config-line)#exec-timeout 0 0
R3(config-line)#exit 
**R3环回**
R3(config)#interface loopback 0
R3(config-if)#ip address 192.168.1.49 255.255.255.248
R3(config-if)#exit 
R3(config)#interface loopback 1
R3(config-if)#ip address 192.168.1.57 255.255.255.248
R3(config-if)#exit 
**R3-R2骨干地址**
R3(config)#interface e1/1
R3(config-if)#ip address 192.168.1.2 255.255.255.240
R3(config-if)#no shutdown 
R3(config-if)#exit 
**R3-R4骨干地址**
R3(config)#interface e1/0
R3(config-if)#ip address 192.168.1.33 255.255.255.240
R3(config-if)#no shutdown 
R3(config-if)#exit
**RIP V2**
R3(config)#router rip  
R3(config-router)#version 2
R3(config-router)#no auto-summary 
R3(config-router)#network 192.168.1.0 
**减少路由条目,环回汇总**
R3(config)#interface e1/1
R3(config-if)#ip summary-address rip 192.168.1.48 255.255.255.240
R3(config-if)#exit 
R3(config)#interface e1/0
R3(config-if)#ip summary-address rip 192.168.1.48 255.255.255.240
R3(config-if)#exit 
**R3-R4开启明文认证**
R3(config)#key chain ccna
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string cisco
R3(config-keychain-key)#exit 
R3(config-keychain)#exit 
R3(config)#interface e1/0
R3(config-if)#ip rip authentication key-chain ccna
**加快收敛速度**
R3(config)#router rip 
R3(config-router)#timers basic 15 90 90 120
R3(config-router)#exit
(4).R4
Router>enable 
Router#configure terminal 
Router(config)#hostname R4
R4(config)#no ip domain-lookup 
R4(config)#line console 0
R4(config-line)#logging synchronous 
R4(config-line)#exec-timeout 0 0
R4(config-line)#exit 
**R4环回地址**
R4(config)#interface loopback 0
R4(config-if)#ip address 192.168.1.81 255.255.255.248
R4(config-if)#exit 
R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.1.89 255.255.255.248
R4(config-if)#exit 
**R4-R3骨干地址**
R4(config)#interface e1/1
R4(config-if)#ip address 192.168.1.34 255.255.255.240
R4(config-if)#no shutdown 
R4(config-if)#exit 
**R4-R5骨干地址**
R4(config)#interface e1/0
R4(config-if)#ip address 192.168.1.65 255.255.255.240
R4(config-if)#no shutdown 
R4(config-if)#exit 
**RIP V2**
R4(config)#router rip  
R4(config-router)#version 2
R4(config-router)#no auto-summary 
R4(config-router)#network 192.168.1.0 
**减少路由条目,环回汇总**
R4(config)#interface e1/1
R4(config-if)#ip summary-address rip 192.168.1.80 255.255.255.240
R4(config-if)#exit 
R4(config)#interface e1/0
R4(config-if)#ip summary-address rip 192.168.1.80 255.255.255.240
R4(config-if)#exit 
**R3-R4开启明文认证**
R4(config)#key chain ccnp
R4(config-keychain)#key 1
R4(config-keychain-key)#key-string cisco
R4(config-keychain-key)#exit 
R4(config-keychain)#exit 
R4(config)#interface e1/1
R4(config-if)#ip rip authentication key-chain ccnp
**R4-R5开启密文认证**
R4(config)#interface e1/0
R4(config-if)#ip rip authentication key-chain ccnp
R4(config-if)#ip rip authentication mode md5 
**加快收敛速度**
R4(config)#router rip 
R4(config-router)#timers basic 15 90 90 120
R4(config-router)#exit
(5).R5
Router>enable 
Router#configure terminal 
Router(config)#hostname R5
R5(config)#no ip domain-lookup 
R5(config)#line console 0
R5(config-line)#logging synchronous 
R5(config-line)#exec-timeout 0 0
R5(config-line)#exit 
**R5环回地址**
R5(config)#interface loopback 0
R5(config-if)#ip address 192.168.1.113 255.255.255.248
R5(config-if)#exit 
R5(config)#interface loopback 1
R5(config-if)#ip address 192.168.1.121 255.255.255.248
R5(config-if)#exit
**R5-R4骨干地址**
R5(config)#interface e1/1
R5(config-if)#ip address 192.168.1.66 255.255.255.240
R5(config-if)#no shutdown 
R5(config-if)#exit 
**R5-R6骨干地址**
R5(config)#interface e1/0
R5(config-if)#ip address 192.168.1.97 255.255.255.240
R5(config-if)#no shutdown 
R5(config-if)#exit
**RIP V2**
R5(config)#router rip  
R5(config-router)#version 2
R5(config-router)#no auto-summary 
R5(config-router)#network 192.168.1.0 
**减少路由条目,手工汇总**
R5(config)#interface e1/0
R5(config-if)#ip summary-address rip 192.168.1.112 255.255.255.240
R5(config-if)#exit 
R5(config)#interface e1/1
R5(config-if)#ip summary-address rip 192.168.1.112 255.255.255.240
R5(config-if)#exit 
**R4-R5之间开启密文认证**
R5(config)#key chain ccie
R5(config-keychain)#key 1
R5(config-keychain-key)#key-string cisco
R5(config-keychain-key)#exit 
R5(config-keychain)#exit 
R5(config)#interface e1/1
R5(config-if)#ip rip authentication key-chain ccie
R5(config-if)#ip rip authentication mode md5 
**加快收敛速度**
R5(config)#router rip 
R5(config-router)#timers basic 15 90 90 120
R5(config-router)#exit
(6).R6
Router>enable 
Router#configure terminal 
Router(config)#hostname R6
R6(config)#no ip domain-lookup 
R6(config)#line console 0
R6(config-line)#logging synchronous 
R6(config-line)#exec-timeout 0 0
R6(config-line)#exit 
**R6环回地址**
R6(config)#interface loopback 0
R6(config-if)#ip address 192.168.1.145 255.255.255.248
R6(config-if)#exit 
R6(config)#interface loopback 1
R6(config-if)#ip address 192.168.1.153 255.255.255.248
R6(config-if)#exit 
**R6-R5骨干地址**
R6(config)#interface e1/1
R6(config-if)#ip address 192.168.1.98 255.255.255.240
R6(config-if)#no shutdown 
R6(config-if)#exit 
**R6-R7骨干地址**
R6(config)#interface e1/0
R6(config-if)#ip address 192.168.1.129 255.255.255.240
R6(config-if)#no shutdown 
R6(config-if)#exit 
**R2-R6**
R6(config)#interface e0/0
R6(config-if)#ip address 192.168.1.161 255.255.255.224
R6(config-if)#no shutdown 
R6(config-if)#exit
**RIP V2**
R6(config)#router rip  
R6(config-router)#version 2
R6(config-router)#no auto-summary 
R6(config-router)#network 192.168.1.0 
**减少路由条目,环回汇总**
R6(config)#interface e1/1
R6(config-if)#ip summary-address rip 192.168.1.144 255.255.255.240
R6(config-if)#exit 
R6(config)#interface e0/0
R6(config-if)#ip summary-address rip 192.168.1.144 255.255.255.240
R6(config-if)#exit 
**加快收敛速度**
R6(config)#router rip 
R6(config-router)#timers basic 15 90 90 120
R6(config-router)#exit
**V1-V2兼容**
R6(config)#interface e1/0
R6(config-if)#ip rip receive version 1 2
R6(config-if)#ip rip send version 1 2
**汇总V2路由条目**
R6(config-if)#ip summary-address rip 192.168.1.0 255.255.255.0

R2通过R6访问R5,与要求不符合,故需做"偏移列表"控制选路

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

**ACL抓取流量,人为增加度量值**
R6(config)#access-list 1 permit 192.168.1.112 0.0.0.15
R6(config)#router rip 
R6(config-router)#offset-list 1 out 3 e0/0

R2去R5的环回汇总通过R6(汇总后为 192.168.1.112/28 )

在这里插入图片描述

写偏移列表后走R3(汇总后为 192.168.1.112/28 )

在这里插入图片描述

(7).R7
Router>enable 
Router#configure terminal 
Router(config)#hostname R7
R7(config)#no ip domain-lookup 
R7(config)#line console 0
R7(config-line)#logging synchronous 
R7(config-line)#exec-timeout 0 0
R7(config-line)#exit 
**R7环回地址**
R7(config)#interface loopback 0
R7(config-if)#ip address 172.16.1.1 255.255.255.0
R7(config-if)#exit 
**R6-R7骨干地址**
R7(config-line)#exit 
R7(config)#interface e1/1
R7(config-if)#ip address 192.168.1.130 255.255.255.240
R7(config-if)#no shutdown 
R7(config-if)#exit
**R7-R8骨干地址**
R7(config)#interface e1/0
R7(config-if)#ip address 78.1.1.1 255.255.255.0
R7(config-if)#no shutdown 
R7(config-if)#exit
*由于172.16.1.0和172.16.2.0属于C类网地址,所以宣告的时候会出现不连续子网问题,需使用第二地址

在这里插入图片描述

R7(config)#interface e1/0
R7(config-if)#ip address 172.16.3.1 255.255.255.0 secondary
R7(config-if)#no shutdown 
**RIP V1**
R7(config)#router rip 
R7(config-router)#no auto-summary 
R7(config-router)#network 172.16.0.0
R7(config-router)#network 78.0.0.0
R7(config-router)#network 192.168.1.0

在这里插入图片描述

**V1-V2兼容**
R7(config)#interface e1/1
R7(config-if)#ip rip receive version 1 2
R7(config-if)#ip rip send version 1 2
R7(config-if)#exit
(8).R8
Router>enable 
Router#configure terminal  
Router(config)#hostname R8
R8(config)#no ip domain-lookup 
R8(config)#line console 0
R8(config-line)#logging synchronous 
R8(config-line)#exec-timeout  0 0
**R8环回地址**
R8(config)#interface loopback 0
R8(config-if)#ip address 172.16.2.1 255.255.255.0
R8(config-if)#exit 
**R8-R7骨干地址**
R8(config)#interface e1/1
R8(config-if)#ip address 78.1.1.2 255.255.255.0
R8(config-if)#no shutdown
R8(config-if)#exit 
**第二地址**
R8(config)#interface e1/1
R8(config-if)#ip address 172.16.3.2 255.255.255.0 secondary 
R8(config-if)#no shutdown 
R8(config-if)#exit 
**开启远程登录**
R8(config)#username xx password yy
R8(config)#line vty 0 4
R8(config-line)#login local 

5.V1-V2兼容性测试

R2访问R8

在这里插入图片描述

6.访问外网测试

R3访问外网

在这里插入图片描述

R8访问外网

在这里插入图片描述

7.远程登录测试

在这里插入图片描述

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值