HDU 1251 统计难题(字典树)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 64511    Accepted Submission(s): 22252


 

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

 

Sample Input

 

banana band bee absolute acm ba b band abc

 

 

Sample Output

 

2 3 1 0

 

 

Author

Ignatius.L

 

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1075 1247 1671 1298 1800 

 

 

Statistic | Submit | Discuss | Note

一道字典树裸题, 没给数据范围,用最原始的写法MLE RE 了一二十发,呜呜, 换指针写法73MB还是超64MB MLE,改成非指针结构体就对了, 不说了上AC代码。

#include<bits/stdc++.h>
using namespace std;
char s[1010];
const int N = 500010;
int tot = 0;
struct node{
	int cnt;
	int next[26];
} r[N];
void insert()
{
	int now = 0;
	char* w = s;
	while (*w)
	{
		int x = *w - 'a';
		if (r[now].next[x] == 0)  // 未编号
			r[now].next[x] = ++tot;
		now = r[now].next[x];  // 向下继续编号
		r[now].cnt++;
		w++;
	}
	return;
}
int search()
{
	int now = 0;
	char* w = s;
	while (*w)
	{
		int x = *w - 'a';
		if (r[now].next[x] == 0) // 未找到以该字母编号的点, 即没有
			return 0;
		now = r[now].next[x];
		w++;
	}
	return r[now].cnt;  // 返回个数
}
int main(){
	while (gets(s))
	{
		if (s[0] == '\0')
			break;
		insert();
	}
	while (~scanf("%s", s))
	{
		cout << search() << endl;
	}
	return 0;
}

指针

#include<bits/stdc++.h>
using namespace std;
char s[1010];
struct node{
	int cnt;
	node* next[26];
}*root;
node* bulid()
{
	node* k = new node;
	k->cnt = 0;
	memset(k->next, 0, sizeof(k->next));
	return k;
}
void insert()
{
	node* r = root;
	char* w = s;
	while (*w)
	{
		int x = *w - 'a';
		if (r->next[x] == NULL)
			r->next[x] = bulid();
		r = r->next[x];
		r->cnt++;
		w++;
	}
	return;
}
int search()
{
	node* r = root;
	char* w = s;
	while (*w)
	{
		int x = *w - 'a';
		if (r->next[x] == NULL)
			return 0;
		r = r->next[x];
		w++;
	}
	return r->cnt;
}
int main(){
	root = bulid();
	while (gets(s))
	{
		if (s[0] == '\0')
			break;
		insert();
	}
	while (~scanf("%s", s))
	{
		cout << search() << endl;
	}
	return 0;
}

 

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值