2019 Multi-University Training Contest 1 1004 : Vacation

5 篇文章 0 订阅

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 587    Accepted Submission(s): 198
Special Judge

 

Problem Description

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The ith car has a length of li, the head of it is si from the stop-line, and its maximum velocity is vi. The car Tom and Jerry are driving is l0 in length, and s0 from the stop-line, with a maximum velocity of v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

 

 

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109). It's guaranteed that si≥si+1+li+1,∀i∈[0,n−1]

 

 

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a, and the jury's answer is b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.
The answer is guaranteed to exist.

 

 

Sample Input

 

1 2 2 7 1 2 1 2 1 2 2 10 7 1 6 2 1

 

 

Sample Output

 

3.5000000000 5.0000000000

 

 

Source

2019 Multi-University Training Contest 1

 

 

Recommend

二分答案 或者 枚举当前车为卡住后面的车辆并取最大值都可以做。

二分需要的时间, zzulioj有个滚球游戏, 跟这有点像, 先计算t秒后的各车位置, 从前往后扫除0号车外, 取卡住每辆车的最大位置, 如果最大位置小于等于0, 即车头到达了0位置, 即满足条件。

#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
typedef long long ll;
const int N = 1e5 + 10;
struct node
{
	ll l, s, v;
}a[N];
double b[N];
int main(){
	int n;
	while (cin >> n)
	{
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].l);
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].s);
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].v);
		double l = 0, r = 1e9;
		double ans = 0;
		for (int c = 0; c <= 50; c++) // 精确到6位, 50够了
		{
			double mid = (l + r) / 2;
			for (int i = 0; i <= n; i++) // 记录t秒后的位置
			{
				b[i] = a[i].s - a[i].v * mid;
			}
			double k = -1e9;
			for (int i = n; i >= 1; i--)
				k = max(k, b[i]) + a[i].l; // 取卡住当前的最大位置, 再加上车长
			k = max(b[0], k); //与0号车比较
			if (k <= 0) // 到达终点
				r = mid, ans = mid;
			else
				l = mid;
		}
		printf("%.10f\n", ans);
	}

	return 0;
}

O(n)

#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
typedef long long ll;
const int N = 1e5 + 10;
struct node
{
	ll l, s, v;
}a[N];
ll b[N];
int main(){
	int n;
	while (cin >> n)
	{
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].l);
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].s);
		for (int i = 0; i <= n; i++)
			scanf("%lld", &a[i].v);
		double ans = 0;
		ll sum = 0;
		for (int i = 1; i <= n; i++)
		{
			ans = max(ans, 1.0 * (sum + a[i].l + a[i].s) / a[i].v);
			sum += a[i].l; // 记录卡住的车的车长之和
		}
		printf("%.10f\n", max(ans, 1.0 * a[0].s / a[0].v));
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值