H - A Simple Triangle NBUT - 1226(模拟)

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.

Output

For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 

Sample Input

3
5
6
7

Sample Output

1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7

Hint

在这个问题中,你需要做一个三角形,就像样本一样。第i行和第j列中的元素

应该是i和j的积。

输入

输入的第一行是一个整数C,表示测试用例的数量。

然后是C测试用例,每个测试用例在上面提到的一行中包含一个整数n(1<=n<=20)。

产量

对于每个测试用例,打印出三角形。用空行分隔的三角形。

如果产品大于9(产品大于9),则应打印一个空格,或打印两个空格。每行的最后一个数字不需要打印空格。

题意:

如果结果大于9在结果后输出一个空格,否则输出两个,翻译的锅。。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int a=n;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=a;j++)
            {
                printf("%d",i*j);
                if(i*j<=9&&j!=a)
                    printf("  ");
                else if(i*j>9&&j!=a)
                    printf(" ");
            }
            a--;
            printf("\n");
        }
        if(t)
            printf("\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值