HDU2602 01背包(裸)模板题

                      HDU2602---Bone Collector

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14

 

二维数组:

//#define _CRT_SECURE_NO_WARNINGS//防止一些函数VS认定不安全而错误
#pragma warning(disable:4996)//屏蔽4996警告信息
#include <iostream>
#include<conio.h>
#include<time.h>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>

typedef long long ll;
typedef long l;
#define fo(i,begin,end) for(int i=begin;i<end;++i)
#define foo(i,begin,end) for(int i=begin;i>end;--i)
#define clr(a) memset(a,0,sizeof(a))
const int maxn = 1005;
using namespace std;
ll dp[maxn][maxn];
ll val[maxn],vol[maxn];

int main()
{
	//freopen("in.txt", "r", stdin);
	ios::sync_with_stdio;
	int t;
	cin >> t;
	while (t--)
	{
		clr(dp);
		clr(val);
		clr(vol);
		
		int n, v;
		cin >> n >> v;
		fo(i, 1, n+1)
			cin >> val[i];//价值
		fo(i, 1, n+1)
			cin >> vol[i];//体积
		fo(i, 1, n+1)
		{
			fo(j, 0, v + 1)
			{
				if (j < vol[i])
					dp[i][j] = dp[i - 1][j];
				else
					dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - vol[i]] + val[i]);
			}
		}
		cout << dp[n][v]<<endl;
	}
	
	return 0;

	
}

滚动数组

//#define _CRT_SECURE_NO_WARNINGS//防止一些函数VS认定不安全而错误
#pragma warning(disable:4996)//屏蔽4996警告信息
#include <iostream>
#include<conio.h>
#include<time.h>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>

typedef long long ll;
typedef long l;
#define fo(i,begin,end) for(int i=begin;i<end;++i)
#define foo(i,begin,end) for(int i=begin;i>end;--i)
#define clr(a) memset(a,0,sizeof(a))
const int maxn = 1005;
using namespace std;
ll dp[maxn];//dp[i]表示i体积下能得到的最大值
ll val[maxn],vol[maxn];

int main()
{
	//freopen("in.txt", "r", stdin);
	ios::sync_with_stdio;
	int t;
	cin >> t;
	while (t--)
	{
		clr(dp);
		clr(val);
		clr(vol);
		
		int n, v;
		cin >> n >> v;
		fo(i, 1, n+1)
			cin >> val[i];//价值
		fo(i, 1, n+1)
			cin >> vol[i];//体积
		fo(i, 1, n+1)
		{
			foo(j,v,vol[i]-1)
			{
					dp[j] = max(dp[j], dp[j - vol[i]] + val[i]);
			}
			
		}
		cout << dp[v]<<endl;
	}
	
	return 0;

	
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

°PJ想做前端攻城狮

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值