PTA 两点间距离计算 (25 分) (继承)

给出下面的一个基类框架:

class Point_1D

{ protected:

float x;//1D 点的x坐标

public:

Point_1D(float p = 0.0);

float distance(const Point_1D & p2);

}

以Point_1D为基类建立一个派生类Point_2D,增加一个保护数据成员:

float y;//2D平面上点的y坐标

以Point_2D为直接基类再建立一个派生类Point_3D,增加一个保护数据成员:

float z;//3D立体空间中点的z坐标

生成上述类并编写主函数,根据输入的点的基本信息,建立点对象,并能计算该点到原点的距离。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(点的类型(1表示1D点,2表示2D点,3表示3D点) 第一个点坐标信息(与点的类型相关) 第二个点坐标信息(与点的类型相关))。当读入0时输入结束,相应的结果不要输出。

输入样例:

1 -1 0

2 3 4 0 0

3 1 2 2 0 0 0

0

输出样例:

Distance from Point -1 to Point 0 is 1

Distance from Point(3,4) to Point(0,0) is 5

Distance from Point(3,3,3) to Point(0,0,0) is 5.19615

实现代码如下:

#include<iostream>
#include<cmath>
using namespace std;
class Point_1D
{ 
   protected:
    float x;//1D 点的x坐标
   public:
     Point_1D(){//默认构造函数 
     	x=0;
	 }
	 void setx(){
	 	cin>>x;
	 }
     void distancex(const Point_1D & p2){
	 	printf("Distance from Point %g to Point %g is %g\n",x,p2.x,fabs(x-p2.x));
	 } 
};
class Point_2D: protected Point_1D{
	protected:
		float y;
	public:
		Point_2D(){//默认构造函数 
			y=0;
		}
		void setxy(){
			cin>>x>>y;
		}
		void distancexy(const Point_2D & p2){
			printf("Distance from Point(%g,%g) to Point(%g,%g) is %g\n",x,y,p2.x,p2.y,sqrt((x-p2.x)*(x-p2.x)+(y-p2.y)*(y-p2.y)));
		}
};
class Point_3D: protected Point_2D{
	protected:
		float z;
	public:
		Point_3D(){
			z=0;
		}
		void setxyz(){
			cin>>x>>y>>z;
		}
		float distancexyz(const Point_3D & p2){
			printf("Distance from Point(%g,%g,%g) to Point(%g,%g,%g) is %g\n",x,y,z,p2.x,p2.y,p2.z,sqrt((x-p2.x)*(x-p2.x)+(y-p2.y)*(y-p2.y)+(z-p2.z)*(z-p2.z)));
		}
};
int main(void)
{
	int a;
	while(scanf("%d",&a)&&a)//输入 
	{
		switch(a)
		{
			case 1:{
			Point_1D p1,p2;
			p1.setx();
			p2.setx();
	        p1.distancex(p2);
			}
	        break;
	        case 2:
	        	{
	        		Point_2D p3,p4;
			p3.setxy();
			p4.setxy();
	        p3.distancexy(p4);
				}
	        break;
	        case 3:{
			Point_3D p5,p6;
			p5.setxyz();
			p6.setxyz();
	        p5.distancexyz(p6);
			} 
	        break;
	       
		}
	}
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值