【C++ 字符串】替换字符串中的字符

仅供本人学习记录
Description
Write a program to input several strings from the keyboard and replace each space in these string with the character ‘@’

Input
输入有多行,第一行输入一个整数N,后面N行每行输入一个字符串,以‘#’为定界符表示字符串结束

Output
输出有N行,每行输出一个替换字符后的字符串

Sample Input
3
A cat#
a b c#
a #
Sample Output
A@cat
a@b@c
a@@@
HINT
注意:输入N后和每个字符串后的回车符的处理

//代码

#include<iostream>//使用@替换空格
#include<string>
using namespace std;
int main()
{
	int a,b=0;
	string str1,str2="@";
	cin>>a;
	while(a--)
	{
		getline(cin,str1,'#');
		while((b=str1.find(" "))!=-1)
			{
				str1.replace(b,1,str2,0,1);
			}
		cout<<str1<<endl;
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值