CCNP 大实验1

在这里插入图片描述
给各个路由器及接口配IP地址
R1路由器:
r2(config)#interface fastEthernet 0/0
r2(config-if)#ip address 172.16.1.1 255.255.255.0
r2(config-if)#no shutdown
r2(config-if)#exit
R2、R3…R12全部配完地址
注意:R4为ISP 使用公网地址

建立MGRE环境 在area0 里建立
缺省条目:
R3(config)#ip route 0.0.0.0 0.0.0.0 172.16.3.2
R5(config)#ip route 0.0.0.0 0.0.0.0 172.16.4.2
R6(config)#ip route 0.0.0.0 0.0.0.0 172.16.5.2
R7(config)#ip route 0.0.0.0 0.0.0.0 172.16.6.2

R3:(中心站点)
R1(config)#int tun 1
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#tunnel source s2/0
R1(config-if)#tunnel mode gre multipoint
R1(config-if)#ip nhrp map multicast dynamic
R1(config-if)#ip nhrp network-id 100

R5:(分支站点)
R5(config)#int tun 1
R5(config-if)#ip address 10.1.1.2 255.255.255.0
R5(config-if)#tunnel source s2/1
R5(config-if)#tunnel mode gre multipoint
R5(config-if)#ip nhrp nhs 10.1.1.1
R5(config-if)#ip nhrp map 10.1.1.1 172.16.3.1
R1(config-if)#ip nhrp network-id 100

R5:(分支站点)
R5(config)#int tun 1
R5(config-if)#ip address 10.1.1.2 255.255.255.0
R5(config-if)#tunnel source s2/1
R5(config-if)#tunnel mode gre multipoint
R5(config-if)#ip nhrp nhs 10.1.1.1
R5(config-if)#ip nhrp map 10.1.1.1 172.16.3.1
R5(config-if)#ip nhrp network-id 100
R6:(分支站点)
R6(config)#int tun 1
R6(config-if)#ip address 10.1.1.2 255.255.255.0
R6(config-if)#tunnel source s2/2
R6(config-if)#tunnel mode gre multipoint
R6(config-if)#ip nhrp nhs 10.1.1.1
R6(config-if)#ip nhrp map 10.1.1.1 172.16.3.1
R6(config-if)#ip nhrp network-id 100
R7:(分支站点)
R7(config)#int tun 1
R7(config-if)#ip address 10.1.1.2 255.255.255.0
R7(config-if)#tunnel source s2/3
R7(config-if)#tunnel mode gre multipoint
R7(config-if)#ip nhrp nhs 10.1.1.1
R7(config-if)#ip nhrp map 10.1.1.1 172.16.3.1
R7(config-if)#ip nhrp network-id 100

分支站点R5,R6,R7开启伪广播R5(config)#int tun 1
R5(config-if)#ip nhrp map multicast 172.16.3.1
R6(config)#int tun 1
R6(config-if)#ip nhrp map multicast 172.16.3.1
R7(config)#int tun 1
R7(config-if)#ip nhrp map multicast 172.16.3.1

全部启用OSPF协议(除了R4以外)
举例R3
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 172.16.1.2 0.0.0.0 area 1
R3(config-router)#network 172.16.2.2 0.0.0.0 area 1
R3(config-router)#network 10.1.1.1 0.0.0.0 area 0(讲隧道口宣布到area 0区域内)
R3(config-router)#network 3.3.3.3 0.0.0.0 area 1(R3的环回依旧在area 1区域内)
R5、R6、R7的OSPF协议都得宣告隧道地址 不能宣告实际地址。

在R3—R7(除R4)的环境中 因为启用OSPF协议 所以需要把隧道接口改为’点到多点‘

举例R3
R3(config)#interface tunnel 0
R3(config-if)#ip ospf network point-to-multipoint
在R9 与 R12上启用重发布来连接不规则区域:
R12(config)#router ospf 1
R12(config-router)#router-id 12.12.12.12
R12(config-router)#network 172.16.8.2 255.255.255.0
R12(config)#router eigrp 90
R12(config-router)#no auto-summary
R12(config-router)#network 100.1.1.1 0.0.0.0
R12(config-router)#network 12.12.12.12
R12(config)#router ospf 1—(重发布)
R12(config-router)#redistribute eigrp 90 subnets—(重发布)
R9(config)#router ospf 1
R9(config-router)#router-id 9.9.9.9
R9(config-router)#network 172.16.10.2 255.255.255.0
R9(config)#router ospf 2
R9(config-router)#network 172.16.11.1 0.0.0.0 area 4
R9(config-router)#network 9.9.9.9 0.0.0.0 area 4
R9(config)#router ospf 1—(重发布)
R9(config-router)#redistribute ospf 2 subnets—(重发布)
R9(config)#router ospf 2—(重发布)
R9(config-router)#redistribute ospf 1 subnets—(重发布)

配置NAT:
R3、R5-7均按如下方法配置:
R3(config)#access-list 1 permit 172.16.0.0 255.255.252.0(R1、R2汇总)
R3(config)#ip nat inside source list 1 int s2/0 overload
R3(config)#int s2/0
R3(config-if)#ip nat outside
R3(config-if)#int f0/0
R3(config-if)#ip nat inside
R3(config-if)#int f1/1
R3(config-if)#ip nat inside

骨干区域汇总------减少路由条目
R3(config)#router ospf 1
R3(config-router)#area 1 range 172.16.0.0 255.255.252.0
R6(config)#router ospf 1
R6(config-router)#area 2 range 172.16.8.0 255.255.248.0R7(config)#router ospf 1

R7(config-router)#area 3 range 172.16.16.0 255.255.252.0域外(OE2)路由器
R12(config)#router ospf 1
R12(config-router)#summary-address 172.16.16.0 255.255.252.0
R9因为 我在图中配了 俩个环回 不能汇总 所以不需要减少

非骨干区域----减少LSA的更新量、
area 1区域内:没有ASBR区域边界路由器(所以需要totally-stub,完全末梢区域–仅保留一条3类的缺省)
优化之后,3类只剩下一条缺省:
R3(config)#router ospf 1
R3(config-router)#area 1 stub no-summary
R1(config-router)#area 1 stub
R2(config-router)#area 1 stubarea 2区域内:有ASBR区域边界路由器(所以需要完全NSSA–在NSSA的基础上进一步拒绝3的LSA,自动产生3类缺省)
优化之后,它应该会删除3、4、5类LSA,然后只保留一条3类缺省,并多出一条7类LSA
R6(config)#router ospf 1
R6(config-router)#area 2 nssa no-summary
R11(config)#router ospf 1
R11(config-router)#area 2 nssa
R12(config)#router ospf 1
R12(config-router)#area 2 nssa
area 3区域内:有ASBR区域边界路由器(所以需要完全NSSA–在NSSA的基础上进一步拒绝3的LSA,自动产生3类缺省)优化之后,它应该会删除3、4、5类LSA,然后只保留一条3类缺省,并多出一条7类LSA:
R7(config)#router ospf 1
R7(config-router)#area 3 nssa no-summaryR8(config)#router ospf 1
R8(config-router)#area 3 nssaR9(config)#router ospf 1
R9(config-router)#area 3 nssa

此时area 3被设置为了NSSA区域,R9拥有了缺省路由,那么我们就可以在R9上的OSPF的进程2中下放缺省,这样才可以出去。
R9(config)#router ospf 2

R9(config-router)#default-information originate–强制下发缺省
此时R10就会有缺省

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值