(kuangbin带你飞--简单搜索)Fire Game FZU2150

原题目:

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input:

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output:

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input:

4

3 3

.#.

###

.#.

3 3

.#.

#.#

.#.

3 3

...

#.#

...

3 3

###

..#

#.#

Sample Output:

Case 1: 1

Case 2: -1

Case 3: 0

Case 4: 2

中文大概题意:

#表示草, .表示石头,从两处地方点火,火只能从草那点,最短时间烧完输出最短时间,烧不完输出-1;

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<fstream>
#include<set>
#include<math.h>
using namespace std;
int n,m;
bool vis[110][110];
int dx[4]={-1,0,0,1};//四个方向 
int dy[4]={0,-1,1,0};
char map[105][105];
int total,cntnum;
struct N
{
	int x,y;
	int step;
};
queue<N> que;
int bfs()
{
	int ans = 0x3f3f;
	while(!que.empty())
	{
		N cnt=que.front();
		que.pop();
		cntnum++;
		if(cntnum==total)
		{
			ans=cnt.step;
			break;
		}
		for(int i=0;i<4;i++)//表示要走四个方向 
		{
			N newp={cnt.x+dx[i],cnt.y+dy[i],cnt.step+1};
			if(newp.x>=0&&newp.x<n&&newp.y>=0&&newp.y<m&&vis[newp.x][newp.y]==0&&map[newp.x][newp.y]=='#')
			{
				vis[newp.x][newp.y]=1;
				que.push(newp);
			}
		}
	}
	while(!que.empty())
	{
		que.pop();
		
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		total=cntnum=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(map[i][j]=='#')
				total++;//记录草数
			}
		}
		int ans= 0x3f3f;//ans为无穷大 
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		for(int k=0;k<n;k++)
		for(int l=0;l<m;l++)
		{
			if(map[i][j]=='#'&&map[k][l]=='#')
			{
				cntnum=0;
				memset(vis,0,sizeof(vis));
				N beg={i,j,0};
				vis[i][j]=1;//记录表示走过,防止走重复
				que.push(beg);
				if(k!=i||l!=j)
				{
					N beg1={k,l,0};
					que.push(beg1);
					vis[k][l]=1;
				} 
				ans=min(ans,bfs());
			}
		}
		printf("Case %d:",k);
		if(ans==0x3f3f)
		{
			printf("-1\n");
		}
		else
		{
			printf("%d\n",ans);
		}
	}
	return 0;
}

思路:(广度优先搜索)

听别人说是还要考虑什么强连通,但是这里好像没有用到呀

别人的思路:

首先,记录所有的草的位置存入结构体中,然后使用bfs进行遍历,遍历的时候需要从两个点开始,然后跑到队列为空结束,输出最后一个数据对应的步数。为什么是输出最后一步的步数,我觉得原因如下:因为并不知道什么时候整个图上的草是否被烧干净,如果每走一步都判断一下是否烧干净的话肯定会超时,最快的时候是两个火相隔比较远并且能充分利用时间,也就是判断最大连通分量。
 

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值