Robberies (01背包问题)

原题目:

Robberies 
Time Limit: 1000msMemory Limit: 32768KB This problem will be judged on HDU. Original ID: 2955 
64-bit integer IO format: %I64d      Java class name: Main 
Prev Submit Status Statistics  Next 
Type:  
None

Tag it! 
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this. 
Input 
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .  
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj . 
Output 
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds. 
Sample Input 

0.04 3 
1 0.02 
2 0.03 
3 0.05 
0.06 3 
2 0.03 
2 0.03 
3 0.05 
0.10 3 
1 0.03 
2 0.02 
3 0.05 
Sample Output 



 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
using namespace std;
const int MAX = 999999;
double dp[10005],p[10005];
int a[111];
int main()
{
    int t;
    while (cin >> t)
    {
        while (t--)
        {
            memset(a, 0, sizeof(a));
            memset(dp, 0, sizeof(dp));
            dp[0] = 1;
            double pp;
            int sum = 0;
            int n;
            cin >> pp >> n;
            for (int i = 1; i <= n; i++)
            {
                cin >> a[i] >> p[i];
                sum += a[i];
                p[i] = 1 - p[i];
            }
            for (int i = 1; i <= n; i++)
                for (int j = sum; j >= a[i]; j--)
                {
                    //dp[j] = max(dp[j], dp[j - a[i]] * p[i]);
                    if (dp[j] <= dp[j - a[i]] * p[i])
                        dp[j] = dp[j - a[i]] * p[i];
                }
            for (int i = sum; i >= 0; i--)
            {
                if (dp[i] >= 1 - pp)
                {
                    cout << i << endl;
                    break;
                }
                //else puts("0");
                if (i == 0)
                    puts("0");
            }
        } 
    }
    return 0;
}

思路:

01,背包直接
把概率当价值,
投的所有前 当背包体积;

确实非常新颖的一道题,但是还是能发现是一道背包问题,因为要输出的东西不一样,所以最后用for循环来进行输出

还得细细品味,毕竟菜是原罪

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值