Compromise (最长公共子序列)

原题目:

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string.h>
#include<string> 
using namespace std;
string s1[1005];
string s2[1005];
int vec[105][105];
int a[1005];
string s;
int main()
{
	int cut1=1,cut2=1;
	while(cin>>s)
	{
		memset(vec,0,sizeof(vec));
		memset(a,0,sizeof(a));
		s1[cut1++]=s;
		while(cin>>s)
		{
			if(s!="#")
			{
				s1[cut1++]=s;
			}
			else
		    {
			break;
		    }
	    } 
		while(cin>>s)
		{
			if(s!="#")
			{
				s2[cut2++]=s;
			}
			else
			{
				break;
			}
		}
		int c=0;
		for(int i=1;i<cut1;i++)
		{
			for(int j=1;j<cut2;j++)
			{
				if(s1[i]==s2[j])
				{
					vec[i][j]=vec[i-1][j-1]+1;
				}
				else
				{
					vec[i][j]=max(vec[i-1][j],vec[i][j-1]);
				}
			}
		}
		int i=cut1-1;
		int j=cut2-1;
		int cut=0;
		while(vec[i][j])
		{
			if(vec[i][j]==vec[i-1][j])
			{
				i--;
			}
			else if(vec[i][j]==vec[i][j-1])
			{
				j--;
			}
			else{
				a[cut++]=i;
			i--;j--;
			
			}
			
		}
		for(i=cut-1;i>0;i--)
	{
		cout<<s1[a[i]]<<' ';
	}
	cout<<s1[a[0]];
	cout<<endl;
	cut1=1;
	cut2=1;
	}
	return 0;
}

中文概要:

两段文字,输出公共单词

思路:

需要记录路径,代码不难

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值