(kuangbin带你飞--kmp)Number Sequence

原题目:

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

思路:
一般的kmp,没有别的区别

#include<stdio.h>
#include<string.h>
int next[10005],lena,lenb;
int a[1000005],b[10005];
void set_naxt()                  //子串的next数组:一个字符串的最长前缀和最长后缀相同的长度
{
    int i=0,j=-1;
    next[0]=-1;                  //初始化为-1,表示不存在相同的最长前缀和最大后缀
    while(i<lenb)
    {
        if(j==-1||b[i]==b[j])
        {
            i++;
            j++;
            next[i]=j;           //把j(相同的最大前缀和最大后缀的长)赋值next[i]
        }
        else
            j=next[j];           //往前回溯
    }
}
int kmp()
{
    int i=0,j=0;                 //比较时j=0
    set_naxt();
    while(i<lena)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;
            j++;
        }
        else
            j=next[j];           //在这里有可能等于-1
        if(j==lenb)
            return i-j+1;
    }
    return -1;
}
int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(next,0,sizeof(next));
        scanf("%d%d",&lena,&lenb);
        for(i=0; i<lena; i++)
            scanf("%d",&a[i]);
        for(i=0; i<lenb; i++)
            scanf("%d",&b[i]);
        printf("%d\n",kmp());
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值