day4 POJ3984

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
分析:bfs简单的走迷宫,难点在于如何记住路线;记住最后输出的坐标还有空格

#include<iostream>
using namespace std;
#include<queue>
char a[10][10];//输入迷宫
bool book[10][10];//标记
int dx[30]={0,1,-1,0};//方向
int dy[30]={-1,0,0,1};
struct node
{
	int x,y;
	int s;//最短路径
	int l[30];//记住路线
};
node bfs();
int main()
{
	memset(book,0,sizeof(book));
	for(int i=1;i<=5;i++)
		for(int j=1;j<=5;j++)
		{
			cin>>a[i][j];
		}
		book[1][1]=1;
		node ans=bfs();
		int x=0,y=0;
		cout<<"(0, 0)"<<endl;
		for(int i=0;i<ans.s;i++)
		{
			x+=dx[ans.l[i]];
			y+=dy[ans.l[i]];
			cout<<"("<<x<<","<<" "<<y<<")"<<endl;
		}
		
}
node bfs()
{
	node pre,next;
	int nx,ny;
	pre.s=0;//开始状态
	pre.x=1;
	pre.y=1;
	queue<node>q;
	q.push(pre);//入队
	while(!q.empty())
	{
		pre=q.front();
		q.pop();
		if(pre.x==5&&pre.y==5)
		return pre;
	for(int i=0;i<4;i++)
	{
		nx=pre.x+dx[i];
		ny=pre.y+dy[i];
		if(nx>=1&&ny>=1&&nx<=5&&ny<=5&&book[nx][ny]==0&&a[nx][ny]=='0')//基本满足条件
		{
			next=pre;
			next.x=nx;
			next.y=ny;
			next.s=pre.s+1;//增加步数
			next.l[pre.s]=i;//记忆路线
			book[nx][ny]=1;//标记
			q.push(next);
	
		}
	}
	}
	return pre;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用径数组记录径。最后,使用栈来输出径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值