day4 hdu241

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
***@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2
分析;题目大意就是有多少块相互隔开的油田,@代表油田,相邻的油田被视为一块
简单dfs找油田,如果找到一块油田就标记为
,避免重复寻找。

#include<iostream>
using namespace std;
#include<iomanip>
#include<cstring>
#include<queue>
char a[103][103];//输入油田

void dfs(int ,int);
int sum=0;
int n,b;
int main()
{
	
	
	while(cin>>n>>b,n,b)
	{
		sum=0;
		memset(book,0,sizeof(book));
		for(int i=1;i<=n;i++)
			for(int j=1;j<=b;j++)
				cin>>a[i][j];
		for(int i=1;i<=n;i++)
			for(int j=1;j<=b;j++)
			{
				if(a[i][j]=='@')
				{
					dfs(i , j);
				sum++;//每找到一块油田加1
				}
			}
			cout<<sum<<endl;
	}

}
void dfs(int x,int y)
{
	a[x][y]='*';//找到一块油田刘标记为*
	int nx,ny;
	int dx[8]={1,0,-1,0,1,-1,1,-1};//方向
	int dy[8]={0,1,0,-1,1,-1,-1,1};
	for(int i=0;i<8;i++)
	{
		nx=x+dx[i];
		ny=y+dy[i];
		if(nx>=1&&ny>=1&&ny<=b&&nx<=n&&a[nx][ny]=='@')//满足条件进入循环
		{
			
			dfs(nx,ny);
			
		}
	}
	return;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值