模拟题Parencodings(Poj1068)简单

题目是括号匹配问题的简单变形,比较水的模拟

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题意:输入一个t,表示t组样例,输入一个n,表示有n个右括号,下面输入n个数,表示每个右括号前有多少个左括号,求括号内的括号对数量。
思路:
方法一:建栈模拟,回溯法查找,数据量非常,暴力回溯不会超时
方法二:用a数组存下每两个右括号中间的左括号数量,然后循环查找与右括号匹配的左括号的位置,嵌套for循环,最后i-j就是要求的数量。
方法三:据说可以打表找规律!!(WTF??!!)

//附上方法二的代码。
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    int T;
    int s[105];
    int a[105];
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&s[i]);
        }
        a[0] = s[1];
        for(int i=1;i<=n;i++){
            a[i] = s[i+1] - s[i];
        }
        int j;
        int cnm;
        for(int i=1;i<=n;i++){
            for( j = i-1;j>=0;j--){
                if(a[j]>0){
                    a[j]--;
                    break;
                }
            }
            if(i!=n)
                cout<<i-j<<" ";
            else{
                cnm = i-j;
            }
        }
        cout<<cnm<<endl;
    }
    return 0;
}

制作人:刘洋港

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值