L - Monitor HDU - 6514(二维差分)(二维前缀和)(动态开二维数组)

Xiaoteng has a large area of land for growing crops, and the land can be s

een as a rectangle of n×m.

But recently Xiaoteng found that his crops were often stolen by a group of people, so he decided to install some monitors to find all the people and then negotiate with them.

However, Xiao Teng bought bad monitors, each monitor can only monitor the crops inside a rectangle. There are p monitors installed by Xiaoteng, and the rectangle monitored by each monitor is known.

Xiao Teng guess that the thieves would also steal q times of crops. he also guessed the range they were going to steal, which was also a rectangle. Xiao Teng wants to know if his monitors can see all the thieves at a time.

Input
There are mutiple test cases.

Each case starts with a line containing two integers n,m(1≤n,1≤m,n×m≤107) which represent the area of the land.

And the secend line contain a integer p(1≤p≤106) which represent the number of the monitor Xiaoteng has installed. This is followed by p lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m) ,meaning the lower left corner and upper right corner of the rectangle.

Next line contain a integer q(1≤q≤106) which represent the number of times that thieves will steal the crops.This is followed by q lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m),meaning the lower left corner and upper right corner of the rectangle.
Output
For each case you should print q lines.

Each line containing YES or NO mean the all thieves whether can be seen.
Sample Input
6 6
3
2 2 4 4
3 3 5 6
5 1 6 2
2
3 2 5 4
1 5 6 5
Sample Output
YES
NO

Hint
In the picture,the red solid rectangles mean the monitor Xiaoteng installed, and the blue dotted rectangles mean the area will be stolen.

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
typedef long long ll;
int n,m;


int main(){
	while(~scanf("%d%d",&n,&m)){
        int **c=new int*[n+2];
        for(int i=0;i<=n+1;i++){
            c[i]=new int[m+2];
        }
        for(int i=0;i<=n+1;i++){
            for(int j=0;j<=m+1;j++){
                c[i][j]=0;
            }
        }
		int p;
		scanf("%d",&p);
		for(int i=1;i<=p;i++){
			int x1,y1,x2,y2;
			scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
			c[x1][y1]++;
			c[x1][y2+1]--;
			c[x2+1][y1]--;
			c[x2+1][y2+1]++;
		}
	
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				c[i][j]+=c[i-1][j]+c[i][j-1]-c[i-1][j-1];
 			}
		}
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				if(c[i][j]) c[i][j]=1;
			}
		}
		
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				c[i][j]+=c[i-1][j]+c[i][j-1]-c[i-1][j-1];
//				printf("%d",c[i][j]);
			}
//			printf("\n");
		}	
		int tp;
		scanf("%d",&tp);
		for(int j=1;j<=tp;j++){
			int x1,y1,x2,y2;
			scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
			ll tem=c[x2][y2]-c[x1-1][y2]-c[x2][y1-1]+c[x1-1][y1-1];
			if(tem==((ll)(x2-x1+1)*(y2-y1+1))) printf("YES\n");
			else printf("NO\n");
		} 
	}
}

版本二

#include <set>
#include <map>
#include <ctime>
#include <queue>
#include <cmath>
#include <stack>
#include <vector>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define eps 1e-6
#define pi acos(-1.0)
#define ll long long int
using namespace std;
 
const int M = (int)1e7;
 
vector < vector<int> > mp;
vector < vector<int> > sum;
 
void init(int n, int m)
{
    mp.clear();
    sum.clear();
    mp.resize(n + 5);
    sum.resize(n + 5);
    for(int i = 0; i < n + 5; ++i)
    {
        mp[i].clear();
        sum[i].clear();
        mp[i].resize(m + 5);
        sum[i].resize(m + 5);
    }
}
 
void get_sum(int n, int m)
{
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 1; j <= m; ++j)
        {
            sum[i][j] = sum[i][j - 1] + sum[i - 1][j] - sum[i - 1][j - 1] + mp[i][j];
        }
    }
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 1; j <= m; ++j)
        {
            if(sum[i][j])
                mp[i][j] = 1;
            else
                mp[i][j] = 0;
            sum[i][j] = 0;
        }
    }
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 1; j <= m; ++j)
        {
            sum[i][j] = sum[i][j - 1] + sum[i - 1][j] - sum[i - 1][j - 1] + mp[i][j];
        }
    }
}
 
int main()
{
    int n, m;
    while(~scanf("%d %d", &n, &m))
    {
        init(n, m);
        int p;
        scanf("%d", &p);
        while((p--) > 0)
        {
            int x1, y1, x2, y2;
            scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
            swap(x1, x2);
            x1 = n - x1 + 1;
            x2 = n - x2 + 1;
            mp[x1][y1]++;
            mp[x2 + 1][y2 + 1]++;
            mp[x1][y2 + 1]--;
            mp[x2 + 1][y1]--;
        }
        get_sum(n, m);
        int q;
        scanf("%d", &q);
        while((q--) > 0)
        {
            int x1, y1, x2, y2;
            scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
            swap(x1, x2);
            x1 = n - x1 + 1;
            x2 = n - x2 + 1;
            int ans = sum[x2][y2] - sum[x1 - 1][y2] - sum[x2][y1 - 1] + sum[x1 - 1][y1 - 1];
            int area = (x2 - x1 + 1) * (y2 - y1 + 1);
            if(ans == area)
                puts("YES");
            else
                puts("NO");
        }
    }
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值