poj3342 Party at Hali-Bula(树形dp)(判断唯一性)

Dear Contestant,

I’m going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I’ve attached the list of employees and the organizational hierarchy of BCM.

Best,
–Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input
6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0
Sample Output
4 Yes
1 No

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<map>
#include<vector>
#include<algorithm> 
using namespace std;
map<string,int> mp;
vector<int> G[300];
int dp[300][300];

void dfs(int i){
	if(G[i].size()==0){
		dp[i][0]=0;
		dp[i][1]=1;
		return;
	}
	for(int j=0;j<G[i].size();j++){
		int u=G[i][j];
		dfs(u);
		dp[i][0]+=max(dp[u][0],dp[u][1]);
		dp[i][1]+=dp[u][0];
	}
	dp[i][1]++;
	return;
}

int main(){
	int n;
	while(~scanf("%d",&n)){
		if(n==0) break;
		for(int i=1;i<=n;i++) G[i].clear();
		memset(dp,0,sizeof(dp));
		int cnt=1;
		mp.clear();
		string s;
		cin>>s;
		if(mp[s]==0) mp[s]=cnt++;
		for(int i=1;i<=n-1;i++){
			string t1,t2;
			cin>>t1>>t2;
			if(mp[t1]==0) mp[t1]=cnt++;
			if(mp[t2]==0) mp[t2]=cnt++;
			G[mp[t2]].push_back(mp[t1]);	
		}
		dfs(1);
		int f=0;
		for(int i=1;i<=n;i++){
			if(dp[i][0]>dp[i][1]){
				for(int j=0;j<G[i].size();j++){
					int u=G[i][j];
					if(dp[u][0]==dp[u][1]){
						f=1;break;
					}
				}
			}
		}
		printf("%d ",max(dp[1][1],dp[1][0]));
		if(f==1||dp[1][1]==dp[1][0]) printf("No\n");
		else printf("Yes\n");
		}
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值