HDU1075(What Are You Talking About)

What Are You Talking About

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(’\t’), enter(’\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i’m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i’m from mars.
i like earth!

思路

map一时爽,一直map一直爽。无奈在练习字典树只能硬着头皮写字典树了,不过字典树的复杂度比map要好一点。

  1. 字典树做法就是存入火星文,然后该火星文会获得一个根值,然后把英文存入这个根值下。这样做的好处就是便于以后快速找到。
    这题唯一的缺点就是不说清楚具体的几个重要参数,导致字典树唯一的不好之处就是数组空间大小只能猜,猜的好AC猜不好不是RE就是TLE(杭电评测系统有时候越界就是给报TLE不给报RE的,刷图论的时候被上了几课之后的感悟)。
//字典树  546ms
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <map> 
using namespace std; 
const int maxn = 1000050;
int trie[maxn][27];
char str[500005][20];
int num[maxn];
int cnt,tot;
void insert(char *s)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - 'a';
		if(!trie[root][k]){
			trie[root][k] = ++cnt;
		}
		root = trie[root][k];
	}
	num[root] = ++tot;
}
int find_s(char *s)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - 'a';
		if(!trie[root][k]){
			return -1;
		}
		root = trie[root][k];
	}
	return num[root];
}
int main()
{
	memset(trie,0,sizeof(trie));
	memset(num,-1,sizeof(num));
	cnt = tot = 0;
	char start[15];
	scanf("%s",start);
	char s[10005],p[10005];
	while(~scanf("%s",s)){
		if(strcmp(s,"END") == 0)	break;
		scanf("%s",p);
		insert(p);
		strcpy(str[tot],s);				//存入这个根植下
	}
	scanf("%s",start);
	getchar();
	while(gets(s)){
		if(strcmp(s,"END") == 0)	break;
		int n = strlen(s);
		int res = 0,flag = 0;
		for(int i = 0;i < n;i++){
			if(s[i] >= 'a' && s[i] <= 'z'){
				p[res++] = s[i];
				if(s[i+1] == '\0'){			//最后一个字符可能就是字母,不特判这一串字符串会忽略。
					p[res] = '\0';			
					int ans = find_s(p);
					if(ans == -1){
						printf("%s",p);
					}
					else{
						printf("%s",str[ans]);
					}
				}
				flag = 1;
			}
			else{
				if(flag == 1){
					p[res] = '\0';
					int ans = find_s(p);				//查找
					if(ans == -1){
						printf("%s",p);
					}
					else{
						printf("%s",str[ans]);
					}
					res = 0;flag = 0;
				}
				printf("%c",s[i]);					//其他字符正常输出。
			}
		}
		printf("\n");
	}	
	return 0;
}
  1. map做法就舒服了,比较轻松的做出来。无脑映射就好,但凡会一点STL都能写出来
//map  889ms
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <map> 
using namespace std;
map<string,string>m; 
int main()
{
	char start[15];
	m.clear();
	map<string,string>::iterator it;
	scanf("%s",start);
	char s[10005],p[10005];
	while(~scanf("%s",s)){
		if(strcmp(s,"END") == 0)	break;
		scanf("%s",p);
		m[p] = s;
	}
	scanf("%s",start);
	getchar();
	while(gets(s)){
		if(strcmp(s,"END") == 0)	break;
		int n = strlen(s);
		int res = 0,flag = 0;
		for(int i = 0;i < n;i++){
			if(s[i] >= 'a' && s[i] <= 'z'){
				p[res++] = s[i];
				if(s[i+1] == '\0'){
					p[res] = '\0';
					it = m.find(p);
					if(it == m.end()){
						printf("%s",p);
					}
					else{
						cout << it->second ;	//这里只能cout输出,printf报错也不知道为什么。
					} 
				}
				flag = 1;
			}
			else{
				if(flag == 1){
					p[res] = '\0';
					it = m.find(p);
					if(it == m.end()){
						printf("%s",p);
					}
					else{
						cout << it->second ;
					} 
					res = 0;flag = 0;
				}
				printf("%c",s[i]);
			}
		}
		printf("\n");
	}	
	return 0;
}

愿你走出半生,归来仍是少年~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值