HDU2328(Corporate Identity)

Corporate Identity

Problem Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

思路

KMP + 暴力枚举,给定若干个字符串找出这些字符串的最长公共子串要求最长而且字典序最小。随便找一个字符串为基准(最好找最短的字符串),然后双重循环枚举子字符串并且与其他字符串做KMP匹配。
一个很让我意外的就是string比char快不少。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
string str[4000];
int num[205];
void get_next(string s)
{
	memset(num,-1,sizeof(num));
	int n = s.length();
	int i = 0,j = -1;
	while(i < n){
		if(j == -1 || s[i] == s[j]){
			i++;j++;
			num[i] = j;
		}
		else{
			j = num[j];
		}
	}
}
bool kmp(string s,string p)
{
	int n = s.length();
	int m = p.length();
	int i = 0,j = 0;
	while(i < n && j < m){
		if(j == -1 || s[i] == p[j]){
			i++;j++;
		}
		else{
			j = num[j];
		}
	}
	if(j == m){
		return true;
	}
	return false;
}
int main()
{
	ios::sync_with_stdio(false);cin.tie(0);
	int t,n;
	while(cin >> n){
		if(n == 0)	break;
		for(int i = 0;i < n;i++){
			cin >> str[i];
		}
		string ans = "";
		int len = str[0].size();
		for(int i = 0;i < len;i++){
			for(int j = 1;j <= len;j++){
				string s = str[0].substr(i,j);
				get_next(s);
				bool f = true;
				for(int k = 1;k < n;k++){
					if(!kmp(str[k],s)){			
						f = false;
						break;			//小优化,一个不匹配就可以直接break。
					}
				}
				if(f){
					if(ans.size() < s.size()){
						ans = s;
					}
					else if(ans.size() == s.size()){
						ans = min(ans,s);
					}
				}
			}
		}
		if(!ans.size()){
			ans = "IDENTITY LOST";
		}
		cout << ans << endl;
	}
	return 0;
}

愿你走出半生,归来仍是少年~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值