POJ3264(Balanced Lineup)

Balanced Lineup

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input

Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

思路

给定一串序列,然后有q次查询每次查询一个区间的最大值和最小值的差是多少。这道题做法很多种,由于是静态的序列可以用RMQ 或者 线段树

  1. 线段树:建立一颗大根树,每次查询复杂度是O(logn),总体时间复杂度O(qlogn)。适用于静态序列和动态序列。

  2. RMQ:本质是dp,预处理打表复杂度O(nlogn),每次查询复杂度O(1)。但是只适用于做静态序列,动态带修改的序列还得用线段树维护。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn = 50005;
const int inf = 0x3f3f3f3f;
int smax[maxn<<2],smin[maxn<<2],a[maxn];
#define lson k<<1,l,m
#define rson k<<1|1,m+1,r
void build(int k,int l,int r)
{
	if(l == r){
		smax[k] = a[l];
		smin[k] = a[l];
		return ;
	}
	int m = (l+r)>>1;
	build(lson);
	build(rson);
	smax[k] = max(smax[k<<1],smax[k<<1|1]);
	smin[k] = min(smin[k<<1],smin[k<<1|1]);
}
int query_max(int k,int l,int r,int ql,int qr)
{
	if(qr < l || ql > r){
		return 0;
	} 
	if(ql <= l && r <= qr){
		return smax[k];
	}
	int m = (l+r)>>1;
	int s1 = query_max(lson,ql,qr);
	int s2 = query_max(rson,ql,qr);
	return max(s1,s2);
}
int query_min(int k,int l,int r,int ql,int qr)
{
	if(qr < l || ql > r){
		return inf;
	} 
	if(ql <= l && r <= qr){
		return smin[k];
	}
	int m = (l+r)>>1;
	int s1 = query_min(lson,ql,qr);
	int s2 = query_min(rson,ql,qr);
	return min(s1,s2);
}
int main()
{
	int t,n,m;
	while(~scanf("%d%d",&n,&m)){
		for(int i = 1;i <= n;i++){
			scanf("%d",&a[i]);
		}
		build(1,1,n);
		while(m--){
			int x,y;
			scanf("%d%d",&x,&y);
			int ans = query_max(1,1,n,x,y) - query_min(1,1,n,x,y);
			printf("%d\n",ans);
		}
	}
	return 0;
}

愿你走出半生,归来仍是少年~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值